Bug 511696 - FTBFS tcl-8.5.6-6.fc11
FTBFS tcl-8.5.6-6.fc11
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tcl (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Nikola Pajkovsky
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
:
Depends On:
Blocks: F12FTBFS
  Show dependency treegraph
 
Reported: 2009-07-14 23:52 EDT by FTBFS
Modified: 2014-02-02 17:13 EST (History)
3 users (show)

See Also:
Fixed In Version: tcl8.5.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-23 05:14:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (26.83 KB, text/plain)
2009-07-14 23:52 EDT, FTBFS
no flags Details
build.log (240.43 KB, text/plain)
2009-07-14 23:52 EDT, FTBFS
no flags Details
mock.log (1015 bytes, text/plain)
2009-07-14 23:52 EDT, FTBFS
no flags Details
root.log (40.11 KB, text/plain)
2009-07-14 23:53 EDT, FTBFS
no flags Details
build.log (223.08 KB, text/plain)
2009-07-14 23:53 EDT, FTBFS
no flags Details
mock.log (946 bytes, text/plain)
2009-07-14 23:53 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2009-07-14 23:52:51 EDT
tcl-8.5.6-6.fc11.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
Comment 1 FTBFS 2009-07-14 23:52:54 EDT
Setting to ASSIGNED per Fedora Bug Triage workflow.  https://fedoraproject.org/wiki/BugZappers/BugStatusWorkFlow
Comment 2 FTBFS 2009-07-14 23:52:56 EDT
Created attachment 353214 [details]
root.log

root.log for i386
Comment 3 FTBFS 2009-07-14 23:52:57 EDT
Created attachment 353215 [details]
build.log

build.log for i386
Comment 4 FTBFS 2009-07-14 23:52:59 EDT
Created attachment 353216 [details]
mock.log

mock.log for i386
Comment 5 FTBFS 2009-07-14 23:53:00 EDT
Created attachment 353217 [details]
root.log

root.log for x86_64
Comment 6 FTBFS 2009-07-14 23:53:01 EDT
Created attachment 353218 [details]
build.log

build.log for x86_64
Comment 7 FTBFS 2009-07-14 23:53:02 EDT
Created attachment 353219 [details]
mock.log

mock.log for x86_64
Comment 8 Marcela Mašláňová 2009-07-17 04:56:31 EDT
This is problem caused by execmod (SElinux). The problem is visible on local build, where the build is failing with different message
"tclsh: error while loading shared libraries: /usr/lib/libtcl8.5.so: cannot restore segment prot after reloc: Permission denied"
and avc message in /var/log/audit/audit.log. One possibility how to track down these kind of problems are these manuals:
http://people.redhat.com/~drepper/selinux-mem.html
http://people.redhat.com/drepper/textrelocs.html

Anyway build wasn't solved yet.

Note You need to log in before you can comment on or make changes to this bug.