Bug 5117 - Intel EEPro100 can destroy networks
Intel EEPro100 can destroy networks
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-13 19:28 EDT by Daniel Senie
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-22 02:33:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Senie 1999-09-13 19:28:53 EDT
Under some circumstances, the EtherExpress Pro 100 can
destroy networks. Discussions of this on the mailing list
hosted by GSFC show that many folks have had different
variations on this.

In my case, an Intel motherboard, L440GX, which contains an
82555 Ethernet chip, will spew massive numbers of duplicate
packets when using multicast. This is consistent with some
software but not all, which tickles the multicast driver
functions. It's not yet clear why.

An interesting note is that enabling promiscuous mode
(either by ifconfig eth0 promisc or by running tcpdump) will
stop the flood of duplicate packets.

The duplicate packets appear to be the result of collision
problems (i.e. the chip apparently thinks it has a
collision, and resends the packet lots of times. In my
network, anything on the same segment as this one server
will croak from overload. Anything on other Ethernet switch
ports will see only the expected traffic. In my case, the
server was running at 100Mbps, half duplex.

This is a complicated set of issues, and one which appears
to be ongoing, based on the info on the GSFC Beowulf
website. Since Intel claims this particular motherboard is
certified for RedHat 6.0, perhaps they'd be willing to help
debug the drivers for this card?
Comment 1 Cristian Gafton 2000-01-04 17:25:59 EST
Assigned to dledford
Comment 2 Cristian Gafton 2000-01-04 17:27:59 EST
Assigned to dledford
Comment 3 Doug Ledford 2000-04-22 02:33:59 EDT
Current versions of the eepro100 driver are thought to work much better.  There
is one thing that can cause the type of behavior noted beyond just a broken
driver, it can be caused when the driver thinks the card should be using half
duplex but the switch the card is plugged into is using full duplex and vice
versa.  Care needs to be taken to make sure there isn't a duplex mis-match.  If
you verify that there isn't a duplex mis-match and that you are using the
current eepro100 driver and you still have a problem, then please re-open the
bug.

Note You need to log in before you can comment on or make changes to this bug.