Bug 511720 - FTBFS sems-1.1.1-5.fc12
FTBFS sems-1.1.1-5.fc12
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: sems (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Reopened
Depends On:
Blocks: F12FTBFS
  Show dependency treegraph
 
Reported: 2009-07-15 00:01 EDT by FTBFS
Modified: 2009-10-18 12:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-18 12:43:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (147.48 KB, text/plain)
2009-07-15 00:01 EDT, FTBFS
no flags Details
build.log (321.01 KB, text/plain)
2009-07-15 00:01 EDT, FTBFS
no flags Details
mock.log (1018 bytes, text/plain)
2009-07-15 00:01 EDT, FTBFS
no flags Details
root.log (248.68 KB, text/plain)
2009-07-15 00:01 EDT, FTBFS
no flags Details
build.log (309.59 KB, text/plain)
2009-07-15 00:01 EDT, FTBFS
no flags Details
mock.log (950 bytes, text/plain)
2009-07-15 00:01 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2009-07-15 00:01:09 EDT
sems-1.1.0-7.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
Comment 1 FTBFS 2009-07-15 00:01:12 EDT
Setting to ASSIGNED per Fedora Bug Triage workflow.  https://fedoraproject.org/wiki/BugZappers/BugStatusWorkFlow
Comment 2 FTBFS 2009-07-15 00:01:15 EDT
Created attachment 353352 [details]
root.log

root.log for i386
Comment 3 FTBFS 2009-07-15 00:01:16 EDT
Created attachment 353353 [details]
build.log

build.log for i386
Comment 4 FTBFS 2009-07-15 00:01:18 EDT
Created attachment 353354 [details]
mock.log

mock.log for i386
Comment 5 FTBFS 2009-07-15 00:01:19 EDT
Created attachment 353355 [details]
root.log

root.log for x86_64
Comment 6 FTBFS 2009-07-15 00:01:20 EDT
Created attachment 353356 [details]
build.log

build.log for x86_64
Comment 7 FTBFS 2009-07-15 00:01:21 EDT
Created attachment 353357 [details]
mock.log

mock.log for x86_64
Comment 8 Jan ONDREJ 2009-07-15 08:41:52 EDT
py_sems module has been disabled, because this module does not compile with newer sip-4.8. Some structures and functions have been silently removed from sip-4.8 without replacement and without any comment. :-(
When support for sip-4.8 will be a part of sems, we should enable this module again.

Build:
http://koji.fedoraproject.org/koji/buildinfo?buildID=114421
Comment 9 Alex Lancaster 2009-08-26 02:32:59 EDT
Re-opening because sems again fails to build from source in rawhide and is causing broken deps:

http://koji.fedoraproject.org/koji/buildinfo?buildID=128564

Culprit appears to be failing to build various mod_ modules, such as mod_dlg.so:

gcc -o mod_dlg.so ModDlg.o   -shared -lm -ldl -rdynamic -lpthread -lm -ldl -rdynamic -lpthread -lm -ldl -rdynamic -lpthread -lm -ldl -rdynamic -lpthread -lm -ldl -rdynamic -lpthread -lm -ldl -rdynamic -lpthread 
/usr/bin/ld: ModDlg.o: relocation R_X86_64_32S against `vtable for DLGModule' can not be used when making a shared object; recompile with -fPIC
ModDlg.o: could not read symbols: Bad value
collect2: ld returned 1 exit status

which are expected in %files list, full log:

http://koji.fedoraproject.org/koji/getfile?taskID=1623135&name=build.log
Comment 10 Peter Lemenkov 2009-10-18 12:43:20 EDT
Finally, it was rebuilt in F-12, so I'm going to close this ticket.

Note You need to log in before you can comment on or make changes to this bug.