Bug 511772 - inn/storage.h not self-contained, missing inn/options.h
inn/storage.h not self-contained, missing inn/options.h
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: inn (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Nikola Pajkovsky
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
:
Depends On:
Blocks: F12FTBFS
  Show dependency treegraph
 
Reported: 2009-07-15 00:12 EDT by FTBFS
Modified: 2014-02-02 17:13 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-14 10:38:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (73.29 KB, text/plain)
2009-07-15 00:13 EDT, FTBFS
no flags Details
build.log (16.14 KB, text/plain)
2009-07-15 00:13 EDT, FTBFS
no flags Details
mock.log (1020 bytes, text/plain)
2009-07-15 00:13 EDT, FTBFS
no flags Details
root.log (91.09 KB, text/plain)
2009-07-15 00:13 EDT, FTBFS
no flags Details
build.log (15.43 KB, text/plain)
2009-07-15 00:13 EDT, FTBFS
no flags Details
mock.log (1.00 KB, text/plain)
2009-07-15 00:13 EDT, FTBFS
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 533933 None None None Never

  None (edit)
Description FTBFS 2009-07-15 00:12:55 EDT
newsx-1.6-11.fc11.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
Comment 1 FTBFS 2009-07-15 00:12:58 EDT
Setting to ASSIGNED per Fedora Bug Triage workflow.  https://fedoraproject.org/wiki/BugZappers/BugStatusWorkFlow
Comment 2 FTBFS 2009-07-15 00:13:00 EDT
Created attachment 353632 [details]
root.log

root.log for i386
Comment 3 FTBFS 2009-07-15 00:13:01 EDT
Created attachment 353633 [details]
build.log

build.log for i386
Comment 4 FTBFS 2009-07-15 00:13:03 EDT
Created attachment 353634 [details]
mock.log

mock.log for i386
Comment 5 FTBFS 2009-07-15 00:13:04 EDT
Created attachment 353635 [details]
root.log

root.log for x86_64
Comment 6 FTBFS 2009-07-15 00:13:07 EDT
Created attachment 353636 [details]
build.log

build.log for x86_64
Comment 7 FTBFS 2009-07-15 00:13:08 EDT
Created attachment 353637 [details]
mock.log

mock.log for x86_64
Comment 8 Dominik 'Rathann' Mierzejewski 2009-09-13 21:39:02 EDT
This FTBFS was caused by a bug in INN (inn/storage.h is no longer self-contained) and, additionally a packaging bug (inn/options.h is not included in -devel).
After manually adding options.h and fixing storage.h to include both defines.h and options.h, newsx builds fine. The self-containment issue is already fixed upstream, according to the Debian bug report http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=533933. Please fix this ASAP so that I can build newsx before beta freeze.

Note You need to log in before you can comment on or make changes to this bug.