Bug 511773 - FTBFS nx-3.3.0-35.fc12
FTBFS nx-3.3.0-35.fc12
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nx (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
:
Depends On: 513753
Blocks: F12FTBFS
  Show dependency treegraph
 
Reported: 2009-07-15 00:13 EDT by FTBFS
Modified: 2009-08-31 10:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-31 10:58:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (150.39 KB, text/plain)
2009-07-15 00:13 EDT, FTBFS
no flags Details
build.log (77.94 KB, text/plain)
2009-07-15 00:13 EDT, FTBFS
no flags Details
mock.log (937 bytes, text/plain)
2009-07-15 00:13 EDT, FTBFS
no flags Details
root.log (315.66 KB, text/plain)
2009-07-15 00:13 EDT, FTBFS
no flags Details
build.log (75.42 KB, text/plain)
2009-07-15 00:13 EDT, FTBFS
no flags Details
mock.log (945 bytes, text/plain)
2009-07-15 00:13 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2009-07-15 00:13:09 EDT
nx-3.3.0-35.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
Comment 1 FTBFS 2009-07-15 00:13:12 EDT
Setting to ASSIGNED per Fedora Bug Triage workflow.  https://fedoraproject.org/wiki/BugZappers/BugStatusWorkFlow
Comment 2 FTBFS 2009-07-15 00:13:15 EDT
Created attachment 353638 [details]
root.log

root.log for i386
Comment 3 FTBFS 2009-07-15 00:13:16 EDT
Created attachment 353639 [details]
build.log

build.log for i386
Comment 4 FTBFS 2009-07-15 00:13:17 EDT
Created attachment 353640 [details]
mock.log

mock.log for i386
Comment 5 FTBFS 2009-07-15 00:13:19 EDT
Created attachment 353641 [details]
root.log

root.log for x86_64
Comment 6 FTBFS 2009-07-15 00:13:20 EDT
Created attachment 353642 [details]
build.log

build.log for x86_64
Comment 7 FTBFS 2009-07-15 00:13:22 EDT
Created attachment 353643 [details]
mock.log

mock.log for x86_64
Comment 8 Axel Thimm 2009-07-25 07:40:41 EDT
The bug is

/usr/include/X11/extensions/XTest.h:50:35: error: X11/extensions/XInput.h: No such file or directory

Both files used to be part of xorg-x11-proto-devel, now they live in libXtst-devel and libXi-devel, but there is no dependency between them.
Comment 9 Alex Lancaster 2009-08-31 05:10:06 EDT
Now causing broken deps:

	nx-3.3.0-35.fc12.i586 requires libcrypto.so.8

http://koji.fedoraproject.org/mash/rawhide-20090830/logs/depcheck

because the openssl soname bump. 

(In reply to comment #8)

> Both files used to be part of xorg-x11-proto-devel, now they live in
> libXtst-devel and libXi-devel, but there is no dependency between them.  

 Is this a simple matter of adding more BuildRequires?
Comment 10 Caolan McNamara 2009-08-31 10:58:11 EDT
I fixed libXsst-devel and rebuilt nx without any modifications of nx. All well as nx-3.3.0-37.fc12.

Note You need to log in before you can comment on or make changes to this bug.