Bug 511798 - ibus input method not functional in eclipse editor
ibus input method not functional in eclipse editor
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-15 00:43 EDT by Martin F
Modified: 2010-05-13 01:54 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-13 01:54:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin F 2009-07-15 00:43:18 EDT
Description of problem:

In eclipse window, I cannot switch between input methods in ibus. I can in most other applications.

Version-Release number of selected component (if applicable):
eclipse-platform-3.4.2-11.fc11.x86_64
ibus-1.1.0.20090612-1.fc11.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Enable Input Method from System->Preferences menu
2. open Eclipse, open a file to edit
3. Move the cursor to Eclipse window and try to activate input method using key combination
  
Actual results:
Ibus icon stays gray and nothing changes

Expected results:
Ibus icon should be highlighted and input language should be displayed when key combo pressed

Additional info:
I did change the key combination to toggle input method activation from Ctrl-Space to various others, to no avail.

Emacs has the same problem, although I can always access the built-in one using Ctrl-\.

Firefox sometimes loses access to ibus, but moving the mouse around and back to any text field gives access, as I can see the icon highlighted and the key combo works.

I manually removed all eclipse language packs, like eclipse-nls-fr. I don't think this should affect input methods.
Comment 1 Andrew Overholt 2009-07-15 10:55:58 EDT
Does this happen because Ctrl-Space is an Eclipse shortcut?
Comment 2 Warren Togami 2009-07-15 11:04:10 EDT
Note: Ctrl-Space is only the Chinese and Indic language activator.  Other languages use language specific activators:

Korean: right-Alt tap
Japanese: Alt-` or Alt-Hankaku/Zenkaku

If you use Chinese/Indic you may need to define an alternative trigger if it conflicts with Eclipse.
Comment 3 Martin F 2009-07-16 14:04:33 EDT
As I already mentioned in the summary, I did re-assign Ctrl-Space to a different key combo (I tried Ctrl-Menu, Alt-grave, etc.) I use US keyboard, and I use ibus for various languages and raw Unicode.

I even tried clicking the ibus icon on the gnome panel with the mouse. Nothing happens and nothing appears in the icon.

I found the following webpage

http://fedoraproject.org/wiki/Test_Days:IBus

and it seems ibus was not tested with eclipse in Fedora 11. Well, we now have the test result: eclipse fails.

BTW, I use US international AltGr deadkey keyboard layout, and changing Win key as Compose allows me to enter accented letters in eclipse, so it must be just the ibus that it's not talking to.
Comment 4 Warren Togami 2009-07-16 14:25:34 EDT
Does Eclipse use GTK+ for widgets?

Anything other than GTK+ needs to use XIM for input methods.
Do other input methods other than ibus work?
Comment 5 Andrew Overholt 2009-07-16 14:34:39 EDT
(In reply to comment #4)
> Does Eclipse use GTK+ for widgets?

Yes.
Comment 6 Andrew Overholt 2009-07-16 14:36:00 EDT
This reminds me of this bug:

https://bugzilla.redhat.com/show_bug.cgi?id=235435
Comment 7 Jens Petersen 2009-07-22 04:13:35 EDT
I just tried on F11 with ibus-1.2.0.20090617-1.fc12.i586
and it works for me.

Do you have ibus-gtk installed?
Comment 8 Jens Petersen 2009-07-22 04:18:49 EDT
Also works with me with f11 ibus.

I suspect you may be missing ibus-gtk.

Otherwise please list the output "rpm -qa ibus\*" and "imsettings-info".
Comment 9 Bug Zapper 2010-04-27 11:41:11 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Peng Huang 2010-05-13 01:54:25 EDT
It works for me.

Note You need to log in before you can comment on or make changes to this bug.