Bug 5118 - kwm uses bad placement for Netscape windows
Summary: kwm uses bad placement for Netscape windows
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase   
(Show other bugs)
Version: 6.0
Hardware: i386 Linux
high
low
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-13 23:53 UTC by Ben Liblit
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-17 15:10:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ben Liblit 1999-09-13 23:53:49 UTC
The KDE window manager (kwm) has a window placement policy
called "smart", which tries to position new windows so that
they have the least possible overlap with existing windows.

When the "kdebase-1.1.1-2" package, this policy is not
applied to Netscape's windows.  Instead, newly mapped
windows are always placed in the top left corner of the
screen, even when the window placement policy is set to
"smart".

(This might apply to all Motif applications, or only to
Netscape.  Since Netscape is the only Motif application on
my box, I can't test how broad the problem is.)

Note:  this is a *regression*!  In "kdebase-1.1.1-1", the
"smart" window placement policy worked just fine for
Netscape windows.

Comment 1 Ben Liblit 1999-09-17 07:36:59 UTC
For what it's worth, this problem also appears in the kdebase-1.1.2-6
rawhide RPM that was recently released.

Comment 2 Preston Brown 1999-09-24 23:42:59 UTC
netscape hardcodes its window placement, and kwm can do nothing to
override this.  the window manager can only make a suggestion.

Unfortunately, this will probably never be fixed.

Comment 3 Ben Liblit 1999-09-25 00:06:59 UTC
Window managers reparent application windows.  Thus, ultimate
authority for the placement of a window does rest with the window
manager, not with the application.  It is applications that suggest
positions, and window managers that choose to respect or ignore them.
So KWM could certainly override Netscape's suggested placement.  (In
fact, that sounds like an excellent candidate for a configuration
option.)

Also, consider the fact that KWM did use its own placement policy in
the "kdebase-1.1.1-1" package.  This is a regression that first
appeared in "kdebase-1.1.1-2".  The Netscape application did not
change in that time period.  Clearly, then, the window manager does
have a say in where windows are placed.

Comment 4 Preston Brown 2000-01-17 15:10:59 UTC
I believe the concensus was to allow programs which specifically requested a
window position to have it; this allows for better session management.

This has not changed even in the latest versions of KDE 1.1.2's CVS tree.


Note You need to log in before you can comment on or make changes to this bug.