Bug 511931 - rpmlint not functioning as expected on spec files
rpmlint not functioning as expected on spec files
Status: CLOSED DUPLICATE of bug 521624
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-15 13:58 EDT by Ankur Sinha (FranciscoD)
Modified: 2009-09-07 06:27 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-15 14:40:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spec file to check for error (75 bytes, text/plain)
2009-07-15 13:58 EDT, Ankur Sinha (FranciscoD)
no flags Details
faulty spec file (81 bytes, text/plain)
2009-07-15 14:02 EDT, Ankur Sinha (FranciscoD)
no flags Details

  None (edit)
Description Ankur Sinha (FranciscoD) 2009-07-15 13:58:28 EDT
Created attachment 353862 [details]
spec file to check for error

Description of problem:
rpmlint does not show error/warning when the changelog release is not same as the release given in tag. It does not give an error when checked with the srpm created. The srpm is created with release number as the one mentioned in the tag and not the one mentioned in the changelog.

Version-Release number of selected component (if applicable):
[Package@Ankur SPECS]$ rpmlint -V
rpmlint version 0.87 Copyright (C) 1999-2007 Frederic Lepied, Mandriva

How reproducible:
While packaging a font, keep the Release tag different from what you use in the changelog. 


Steps to Reproduce:
1.create a spec
2.write a value for Release tag
3.write a different release value in the changelog
4.run rpmlint -i on the spec
  
Actual results:
no errors/warnings

Expected results:
error/warning for incoherent release number in changelog

Additional info:
Comment 1 Ankur Sinha (FranciscoD) 2009-07-15 14:02:24 EDT
Created attachment 353864 [details]
faulty spec file

this is the faulty spec that isnt returning an error. the other attachment is the original spec.
Comment 2 Ville Skyttä 2009-07-15 14:40:48 EDT
See CAVEATS in the rpmlint man page.  About this particular case, incoherent-version-in-changelog check is done only on binary packages.
Comment 3 Karel Volný 2009-09-07 06:27:56 EDT
I'm changing the resolution to duplicate of #521624 as this is just another occurence of the common problem that is described there.

*** This bug has been marked as a duplicate of bug 521624 ***

Note You need to log in before you can comment on or make changes to this bug.