Bug 511980 - No sound on Dell Latitude C640 since upgrade to F11
No sound on Dell Latitude C640 since upgrade to F11
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-15 16:40 EDT by Frank
Modified: 2010-06-07 13:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-07 13:20:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Frank 2009-07-15 16:40:20 EDT
Description of problem:
Upgraded to Fedora 11 on Dell Latitude C640: no sound. Worked perfectly well before. Everything seems in place, no error messages, all applications work, but no sound. I feel I checked everything... Nothing is muted, all levels are at 100%,  all modules and drivers loaded. I googled and searched bugzilla and a 100 other places, tried all modifications in /etc/modprobe.d/alsa.conf suggested that i could find, reinstalled pulsaudio, and followed all hints that had "no sound in F11" printed on them.
Sorry if I overlooked something, but I searched for days without result...  

Version-Release number of selected component (if applicable):
Kernel 2.6.29.5-191.fc11.i686.PAE

alsa-info: see below

How reproducible:

It's always there

Steps to Reproduce:
1. turn on computer
2. play any file, or youtube, with any software 
3. don't hear anything
  
Actual results:

no sound

Expected results:

sound

Additional info:

Some output of alsa.conf:

!!ALSA Version
!!------------

Driver version:     1.0.18a
Library version:    
Utilities version:  1.0.20


!!Loaded ALSA modules
!!-------------------

snd_intel8x0
snd_intel8x0m


!!Sound Servers on this system
!!----------------------------

Pulseaudio:
      Installed - Yes (/usr/bin/pulseaudio)
      Running - Yes


!!Soundcards recognised by ALSA
!!-----------------------------

 0 [I82801CAICH3   ]: ICH - Intel 82801CA-ICH3
                      Intel 82801CA-ICH3 with CS4205 at irq 5
 1 [Modem          ]: ICH-MODEM - Intel 82801CA-ICH3 Modem
                      Intel 82801CA-ICH3 Modem at irq 5


!!PCI Soundcards installed in the system
!!--------------------------------------

00:1f.5 Multimedia audio controller: Intel Corporation 82801CA/CAM AC'97 Audio Controller (rev 02)


!!Advanced information - PCI Vendor/Device/Susbsystem ID's
!!--------------------------------------------------------

00:1f.5 0401: 8086:2485 (rev 02)
	Subsystem: 1013:5959


!!Modprobe options (Sound related)
!!--------------------------------

snd-intel8x0: ac97_clock=41000


!!Loaded sound module options
!!--------------------------

!!Module: snd_intel8x0
ac97_clock : 41000
ac97_quirk : <NULL>
buggy_irq : N
buggy_semaphore : N
enable : N
id : <NULL>
index : -1
joystick : 0
spdif_aclink : 0
xbox : N

!!Module: snd_intel8x0m
ac97_clock : 0
enable : N
id : <NULL>
index : -2


!!AC97 Codec information
!!---------------------------
--startcollapse--

0-0/0: Cirrus Logic CS4205 rev 3

PCI Subsys Vendor: 0x1013
PCI Subsys Device: 0x5959

Capabilities     : -dedicated MIC PCM IN channel- -bass & treble- -simulated stereo- -loudness-
DAC resolution   : 20-bit
ADC resolution   : 18-bit
3D enhancement   : SRS 3D Stereo Enhancement

Current setup
Mic gain         : +0dB [+0dB]
POP path         : pre 3D
Sim. stereo      : off
3D enhancement   : off
Loudness         : off
Mono output      : MIX
Mic select       : Mic1
ADC/DAC loopback : off
Extended ID      : codec=0 rev=0 AMAP DSA=0 VRM VRA
Extended status  : PRL VRM VRA
PCM front DAC    : 44100Hz
PCM ADC          : 44100Hz
PCM MIC ADC      : 48000Hz
SPDIF Control    : Consumer PCM Category=0x2 Generation=1 Rate=48kHz
Comment 1 Frank 2009-07-18 08:12:49 EDT
Well, simple solution is that after opening Preferences->"Advanced volume control" and just *touching* the PCM control (which was already at 100% unmuted), sound reappeared.
I leave this open because it's still a bug, but no longer a serious one.
Comment 2 Bug Zapper 2010-04-27 11:42:42 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.