Bug 512000 - rename qca2 -> qca
rename qca2 -> qca
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qca2 (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: FutureFeature, Reopened
Depends On: qca
Blocks: F14Target psi-plus
  Show dependency treegraph
 
Reported: 2009-07-15 18:06 EDT by Rahul Sundaram
Modified: 2015-06-21 17:47 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-01 10:55:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2009-07-15 18:06:16 EDT
Description of problem:


This package is misnamed. A plugin for a package named qca2 shouldn't be called qca-ossl. It is frustrating confusing c.f. discussions in fedora-kde list on kmess as well.
Comment 1 Bug Zapper 2009-11-16 06:00:03 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Rex Dieter 2010-01-29 13:30:44 EST
I think the consensus it so deprecate qca (v1 for qt3) and rename qca2 (for qt4) to qca for f13.  

(Probably should've caught this inconsistent naming mess earlier, but better late than never)
Comment 3 Rex Dieter 2010-01-29 13:33:30 EST
In the meantime would adding something like
Provides: qca2-ossl = %{version}-%{release}
to the existing qca-ossl for previous releases help?
Comment 5 Chen Lei 2010-05-25 02:25:34 EDT
(In reply to comment #2)
> I think the consensus it so deprecate qca (v1 for qt3) and rename qca2 (for
> qt4) to qca for f13.  
> (Probably should've caught this inconsistent naming mess earlier, but better
> late than never)    

It's a good idea, qca is already deprecated in F13. Open a new review for qca and retire qca2 seems reasonable, because qca is migrating to cmake buildsys from qconf/qmake recently.
Comment 6 Rex Dieter 2010-09-14 10:57:27 EDT
In todays, kde-sig meeting, we considered simply renaming qca2 -> qca to be a simpler way forward.

Any comments or objections to that plan?
Comment 7 Chen Lei 2010-09-14 12:53:08 EDT
Which source file should we use - qca release tarball or svn snapshot? It seems the release tarball is a bit old and the svn snapshot add cmake support for qca2.
Comment 8 Rex Dieter 2010-09-14 12:58:02 EDT
That's beyond the scope of renaming, it's up to to you/maintainers.

Now, if it were *me*, I'd investigate the snapshot/cmake idea for rawhide as well as pinging upstream wrt plans/schedules for future releases.
Comment 10 Ivan Romanov 2013-09-01 17:44:20 EDT
Hello.
Now I am a developer of qca. I am planing to release Qca 2.1.0 within 2 month. This version will merge all plugins in single tarball/package.
Also added Qt5 support and removed qconf/qmake build rules. Now it is using only cmake.
Comment 11 Rex Dieter 2014-09-23 13:11:20 EDT
I guess we let this linger long enough, let's consider it WONTFIX.

As for a newer qca release, did that ever happen?  Where is it?  How can one get it?
Comment 12 Ivan Romanov 2014-09-23 13:19:19 EDT
I want to fix qca-gnupg plugin before. And there is one issue with qca-ossl 
https://bugzilla.redhat.com/show_bug.cgi?id=1144655.

The latest sources you can get always from http://quickgit.kde.org/?p=qca.git
Comment 13 Ivan Romanov 2014-11-14 07:46:49 EST
New QCA release here https://bugzilla.redhat.com/show_bug.cgi?id=1161767 . Will want updating package in Fedora.
Comment 14 Rex Dieter 2014-11-14 08:09:01 EST
Re-opening, we can implement this now, I see old qca was retired, and the major re-work in qca-2.1.0 warrants it I think.
Comment 15 Rex Dieter 2014-11-14 13:08:12 EST
qca pkg review, bug #1164348
Comment 16 Rex Dieter 2014-12-01 10:55:35 EST
qca2 retired in rawhide, due to pkg rename bug #1164348
Comment 17 nucleo 2014-12-01 11:01:22 EST
(In reply to Rex Dieter from comment #16)
> qca2 retired in rawhide, due to pkg rename bug #1164348

The same should be with qca-cyrus-sasl, qca-pkcs11, qca-ossl and qca-gnupg packages?
Comment 18 Rex Dieter 2014-12-01 11:02:28 EST
the plugin/subpkgs were already all named qca-<...>, that's why we wanted to rename things to be consistent. :)
Comment 19 nucleo 2014-12-01 11:04:12 EST
I mean that separate plugins packages should be retired.
Comment 20 Rex Dieter 2014-12-01 11:23:59 EST
ah yes, you are right in that regard, thanks!

Note You need to log in before you can comment on or make changes to this bug.