Bug 51212 - pdksh-5.2.14-13 annoying tty message
Summary: pdksh-5.2.14-13 annoying tty message
Status: CLOSED DUPLICATE of bug 51044
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: pdksh (Show other bugs)
(Show other bugs)
Version: roswell
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-08 15:07 UTC by Mike Sklar
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-14 18:33:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike Sklar 2001-08-08 15:07:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010712

Description of problem:
pdksh-5.2.14-13 that has shown up with roswell has a awfully annoying tty
job control message being printed to STDOUT when ksh is invoked.

busted5$ ksh
ksh: No controlling tty (open /dev/tty: No such device or address)
ksh: warning: won't have full job control


How reproducible:
Always

Steps to Reproduce:
1. type 'ksh'
2.
3.
	

Actual Results:  busted5$ ksh
ksh: No controlling tty (open /dev/tty: No such device or address)
ksh: warning: won't have full job control


Expected Results:  no printing of tty warning

Additional info:

5.2.14-12 did not have this 'feature', could this not be enabled by default?

Comment 1 Trond Eivind Glomsrxd 2001-08-08 18:15:58 UTC
It doesn't happen for me - it works fine.

The only change from -12 (shipped in RHL 7.1) to -13 is a rebuild, and I can't
reproduce the problem. Have you done anything to your system, like compiling
your own kernel?

Comment 2 Glen Foster 2001-08-08 19:12:56 UTC
We (Red Hat) should try to fix this before next release.

Comment 3 Mike Sklar 2001-08-08 19:14:41 UTC
I'll do some additional checking and see if I can figure what is causing the
message to be displayed, and if it is indeed coming from the ksh sources. I'm
using the stock 2.4.6-3.1 kernel provided by redhat.

asdfjkl$ rsh busted4
ksh: No controlling tty (open /dev/tty: No such device or address)
ksh: warning: won't have full job control
busted4$ uname -a
Linux busted4 2.4.6-3.1smp #1 SMP Tue Jul 24 15:38:18 EDT 2001 ia64 unknown
busted4$

Comment 4 Trond Eivind Glomsrxd 2001-08-08 19:20:25 UTC
Can you try util-linux from the rawhide push yesterday (util-linux-2.11f-8
)?

Comment 5 Mike Sklar 2001-08-08 19:34:58 UTC
No help.

# rpm -Uvh util-linux-2.11f-8.ia64.rpm --force --nodeps
Preparing...                ########################################### [100%]
   1:util-linux             ########################################### [100%]
# ksh
ksh: No controlling tty (open /dev/tty: No such device or address)
ksh: warning: won't have full job control
# 


Comment 6 Trond Eivind Glomsrxd 2001-08-08 19:40:02 UTC
Can you check if this is a problem also after a restart? I'm not sure what could
cause this... I'm confident it's not pdksh problem, and it doesn't happen for me
with same ksh (but newer binaries all around it..)

Comment 7 Mike Sklar 2001-08-14 18:33:19 UTC
The issue appears to be rather transient. I don't get it on every single login. 

asdfjkl$ rsh busted4
ksh: No controlling tty (open /dev/tty: No such device or address)
ksh: warning: won't have full job control
busted4$ exit
rlogin: connection closed.
asdfjkl$ rsh busted4
busted4$ 


Comment 8 Trond Eivind Glomsrxd 2001-08-21 14:33:19 UTC

*** This bug has been marked as a duplicate of 51044 ***


Note You need to log in before you can comment on or make changes to this bug.