This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 512123 - Installation timeout when installing tog-pegasus and tog-pegasus-devel
Installation timeout when installing tog-pegasus and tog-pegasus-devel
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sblim (Show other bugs)
5.4
powerpc Linux
high Severity high
: rc
: 5.4
Assigned To: Vitezslav Crhonek
BaseOS QE
: Regression
Depends On:
Blocks: RHEL5u4_relnotes
  Show dependency treegraph
 
Reported: 2009-07-16 09:06 EDT by Martin Banas
Modified: 2009-09-02 05:18 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
when the sblim-cmpi-dhcp package is installed, it modifies the files under /var/lib/Pegasus owned by the tog-pegasus package. Previously, when sblim was installed in the course of an "everything" installation of Red Hat Enterprise Linux 5 on the PowerPC architecture, the modifications that sblim made in the /var/lib/Pegasus directory prevented the post-install scriptlet from completing the provider-register commands. In turn, this would prevent installation of Red Hat Enterprise Linux 5 from completing. The provider-register commands are no longer provided in the post-install scriptlet, therefore avoiding this situation and allowing installation of the operating system to complete normally. Users of SBLIM who need to register provider modules for tog-pegasus should register these modules manually by running the following command as root: /usr/share/sblim-cmpi-dhcp/provider-register.sh -t pegasus -v -n "root/PG_InterOp" -r /usr/share/sblim-cmpi-dhcp/Linux_DHCPRegisteredProfile.registration /usr/share/sblim-cmpi-dhcp/Linux_DHCPElementConformsToProfile.registration -m /usr/share/sblim-cmpi-dhcp/Linux_DHCPService.mof /usr/share/sblim-cmpi-dhcp/Linux_DHCPRegisteredProfile.mof /usr/share/sblim-cmpi-dhcp/Linux_DHCPElementConformsToProfile.mof Accordingly, deregister modules before update/remove of the sblim-cmpi-dhcp package with following command as root: /usr/share/sblim-cmpi-dhcp/provider-register.sh -d -t pegasus -n "root/PG_InterOp" -r /usr/share/sblim-cmpi-dhcp/Linux_DHCPRegisteredProfile.registration /usr/share/sblim-cmpi-dhcp/Linux_DHCPElementConformsToProfile.registration -m /usr/share/sblim-cmpi-dhcp/Linux_DHCPService.mof /usr/share/sblim-cmpi-dhcp/Linux_DHCPRegisteredProfile.mof /usr/share/sblim-cmpi-dhcp/Linux_DHCPElementConformsToProfile.mof
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:18:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/lib/Petasus/log/install.log (58 bytes, application/octet-stream)
2009-07-23 06:17 EDT, Martin Banas
no flags Details
screenshot showing installation hang at tog-pegasus package (57.79 KB, image/png)
2009-07-27 10:32 EDT, Brock Organ
no flags Details

  None (edit)
Comment 1 Chris Lumens 2009-07-16 09:51:48 EDT
What's the tog-pegasus-devel package's scritplet doing?
Comment 2 Martin Banas 2009-07-17 03:22:42 EDT
it seems tog-pegasus-devel is not installed.
#rpm -q	tog-pegasus-devel
package tog-pegasus-devel is not installed

attached top and "ps -A" logs.
Comment 4 Martin Banas 2009-07-17 03:24:14 EDT
Created attachment 354105 [details]
top log
Comment 5 Denise Dumas 2009-07-17 10:01:58 EDT
Adding tog-pegasus maintainer ...
Comment 7 Chris Lumens 2009-07-17 13:04:15 EDT
Not sure what provides /usr/bin/repupgrade, but that looks to be the process taking all of the time.  If that's a lengthy process (or if the program has a bug that causes it to chew CPU), that could very well make anaconda look like it's hung.  Unfortunately we don't get any progress information from rpm that allows us to inform the user.
Comment 8 Vitezslav Crhonek 2009-07-20 06:48:09 EDT
/usr/bin/repupgrade is tool for upgrading the contents of a repository based on older version of schema (/var/lib/Pegasus/prev_repository) to a repository based on the new schema (/var/lib/Pegasus/repository).

/var/lib/Pegasus/prev_repository is created when updating (rpm -U) tog-pegasus package, it's just a copy of /var/lib/Pegasus/repository before update. When installing for the first time (rpm -i), there should be no old repository and /usr/bin/repupgrade should not be executed at all.

/usr/bin/repupgrade process take a few seconds usually.

You can also check /var/lib/Pegasus/log/install.log.
Comment 9 Denise Dumas 2009-07-20 15:40:39 EDT
Given where we are in 5.4, should we release note this, since a reasonable workaround exists and its only the devel package that most users would not be installing anyway?
Comment 10 Martin Banas 2009-07-21 04:52:40 EDT
This will affect all users installing @Everything package set.
Comment 11 Martin Banas 2009-07-21 07:26:28 EDT
The same behaviour with latest RHEL5.4-20090721.nightly
Comment 13 Denise Dumas 2009-07-21 09:01:45 EDT
Can someone please attach the /var/lib/Pegasus/log/install.log mentioend in comment 8?
Comment 15 Denise Dumas 2009-07-21 11:28:38 EDT
So are we saying that all @everything installs on all arches hang because of this problem?
Comment 19 Martin Banas 2009-07-23 06:17:25 EDT
Created attachment 354837 [details]
/var/lib/Petasus/log/install.log
Comment 20 Vitezslav Crhonek 2009-07-23 06:39:54 EDT
(In reply to comment #19)
> Created an attachment (id=354837) [details]
> /var/lib/Petasus/log/install.log  

Just timestamps from both installation %post scripts. No output from repupgrade to stderr (which is redirected to this log).
Comment 24 Brock Organ 2009-07-27 10:32:25 EDT
Created attachment 355282 [details]
screenshot showing installation hang at tog-pegasus package
Comment 28 Denise Dumas 2009-07-28 10:25:43 EDT
Do we agree that the problem seems to be in the tog-pegasus repupgrade tool, or in the script that uses it?
Comment 41 Vitezslav Crhonek 2009-08-05 08:23:10 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
The sblim-cmpi-dhcp package does not register provider modules to "root/PG_InterOp" namespace of the tog-pegasus repository. If you need these provider modules, you can register them lately with following command as root:

/usr/share/sblim-cmpi-dhcp/provider-register.sh -t pegasus -v -n
"root/PG_InterOp" -r
/usr/share/sblim-cmpi-dhcp/Linux_DHCPRegisteredProfile.registration
/usr/share/sblim-cmpi-dhcp/Linux_DHCPElementConformsToProfile.registration -m
/usr/share/sblim-cmpi-dhcp/Linux_DHCPService.mof
/usr/share/sblim-cmpi-dhcp/Linux_DHCPRegisteredProfile.mof
/usr/share/sblim-cmpi-dhcp/Linux_DHCPElementConformsToProfile.mof

Accordingly, deregister modules before update/remove of the sblim-cmpi-dhcp package with following command as root:

/usr/share/sblim-cmpi-dhcp/provider-register.sh -d -t pegasus -n
"root/PG_InterOp" -r
/usr/share/sblim-cmpi-dhcp/Linux_DHCPRegisteredProfile.registration
/usr/share/sblim-cmpi-dhcp/Linux_DHCPElementConformsToProfile.registration -m
/usr/share/sblim-cmpi-dhcp/Linux_DHCPService.mof
/usr/share/sblim-cmpi-dhcp/Linux_DHCPRegisteredProfile.mof
/usr/share/sblim-cmpi-dhcp/Linux_DHCPElementConformsToProfile.mof
Comment 43 Jan Stodola 2009-08-10 17:13:58 EDT
Manual installations confirm results from rhts - installations finished successfully. Also no problem when performing installation described in comment 29.
Tested with RHEL5.4 RC1, sblim-cmpi-dhcp-0.5.5-35.el5, tog-pegasus-2.7.2-1.el5 on ppc.
Moving to VERIFIED.
Comment 48 Ruediger Landmann 2009-08-30 21:03:36 EDT
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1,4 +1,16 @@
-The sblim-cmpi-dhcp package does not register provider modules to "root/PG_InterOp" namespace of the tog-pegasus repository. If you need these provider modules, you can register them lately with following command as root:
+when the sblim-cmpi-dhcp package is installed, it modifies the 
+files under /var/lib/Pegasus owned by the tog-pegasus package. 
+Previously, when  sblim was installed in the course of an "everything" 
+installation of Red Hat Enterprise Linux 5 on the PowerPC architecture, 
+the  modifications that sblim made in the /var/lib/Pegasus directory 
+prevented the post-install scriptlet from completing the 
+provider-register commands. In turn, this would prevent installation
+of Red Hat Enterprise Linux 5 from completing. The provider-register
+commands are no longer provided in the post-install scriptlet, 
+therefore avoiding this situation and allowing installation of the 
+operating system to complete normally. Users of SBLIM who need to 
+register provider modules for tog-pegasus should register these 
+modules manually by running the following command as root:
 
 /usr/share/sblim-cmpi-dhcp/provider-register.sh -t pegasus -v -n
 "root/PG_InterOp" -r
Comment 49 errata-xmlrpc 2009-09-02 05:18:41 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1267.html

Note You need to log in before you can comment on or make changes to this bug.