Bug 51224 - printers from 7.1 don't work
printers from 7.1 don't work
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-08 12:05 EDT by Gerald Teschl
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-21 12:44:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
loacl.adl created with printconf-gui from 7.1 (1.22 KB, text/plain)
2001-08-09 04:47 EDT, Gerald Teschl
no flags Details

  None (edit)
Description Gerald Teschl 2001-08-08 12:05:56 EDT
I have a local hp lj 1100 set up under redhat 7.1. If I open
printtool it will show up us such, but if I click on edit
it is listed as "unix lpd" and all driver options (paper options ...)
are reset to the default values.
Comment 1 Glen Foster 2001-08-08 15:07:32 EDT
This defect is considered MUST-FIX for Fairfax.
Comment 2 Crutcher Dunnavant 2001-08-08 15:32:46 EDT
does the same problem happen in printconf-tui? Can you attach the output of:

 zcat /etc/alchemist/namespace/printconf/local.adl

to this bug.
Comment 3 Gerald Teschl 2001-08-09 04:45:54 EDT
No it doesn't seem to happen with tui, but its hard to say since it crashes at
various points.

E.g. Edit ->Driver:
-----------------------------------------------------------------------
[root@tomcat gerald]# printconf-tui
Initializing alchemist edit environment ...
Initializing linux printing database ...
Traceback (innermost last):
  File "/usr/sbin/printconf-tui", line 7, in ?
    import printconf_tui
  File "/usr/share/printconf/util/printconf_tui.py", line 2057, in ?
    if main.cmd_handlers.has_key(cmd):
  File "/usr/share/printconf/util/printconf_tui.py", line 1953, in tui_main_run
    qlf_run()
  File "/usr/share/printconf/util/printconf_tui.py", line 1850, in qlf_run
    elif qed_run(queue_dict):
  File "/usr/share/printconf/util/printconf_tui.py", line 829, in qed_run
    qed_ded_run()
  File "/usr/share/printconf/util/printconf_tui.py", line 1462, in qed_ded_run
    driver_tree = driver_tree_checkboxtree(height = height - 3, width = width)
  File "/usr/share/printconf/util/printconf_tui.py", line 758, in
driver_tree_checkboxtree
    driver_tree = CheckboxTree(height = height, width = width, scroll = 1,
hide_checkbox = 1, unselectable = 1)
TypeError: unexpected keyword argument: unselectable
Comment 4 Gerald Teschl 2001-08-09 04:47:08 EDT
Created attachment 26976 [details]
loacl.adl created with printconf-gui from 7.1
Comment 5 Crutcher Dunnavant 2001-08-09 16:31:42 EDT
this is a result of us running into the new foomatic option indexing. I need a
better resolution that this, but it depends upon Grant Taylor blessing a One
True Way. I will find an answer to this.
Comment 6 Crutcher Dunnavant 2001-08-09 23:21:20 EDT
btw, the traceback there is a dependancy on a newer version of newt.
Comment 7 Crutcher Dunnavant 2001-08-10 19:05:41 EDT
okay, fixed the rest of this.
Comment 8 Gerald Teschl 2001-08-21 12:44:55 EDT
Doesn't seem entirely fixed here. If I boot the system with the old configuration
it will tell me "no printers definedn" and /etc/printcap is empty.
If I open printtol and press "apply", the printers will show up in
/etc/printcap.
Comment 9 Crutcher Dunnavant 2001-08-21 15:05:16 EDT
I'm forcing a dirty state now.

Note You need to log in before you can comment on or make changes to this bug.