Bug 512295 - No common provides to php and php-pecl-json
Summary: No common provides to php and php-pecl-json
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: php-pecl-json
Version: el5
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jon Stanley
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-07-17 06:38 UTC by Remi Collet
Modified: 2009-08-05 17:23 UTC (History)
2 users (show)

Fixed In Version: 1.2.1-4.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-05 17:23:09 UTC


Attachments (Terms of Use)

Description Remi Collet 2009-07-17 06:38:50 UTC
Hi,

I have a application (GLPI) which requires the "json" extension to work.

The issue is that there is no common requires we could use to have php-common >= 5.2.x (Fedora) or php-pecl-json (PECL) in the dependencies.

php-common only provides 
   php-json

php-pecl-json provides (according to the Guidelines)
   php-pecl(json)
   php-pecl-json


The simplest solution seems to add "php-json" to php-pecl-json in EPEL,

@Jstanley, if you're ok, I will add it

@Joe Orton, if you're ok, we could also add php-pecl(json) to php in rawhide (and perhaps in F10, F11 if an update for another reason is needed)

What about this ?

Comment 1 Joe Orton 2009-07-17 07:09:50 UTC
> @Joe Orton, if you're ok, we could also add php-pecl(json) to php in rawhide
> (and perhaps in F10, F11 if an update for another reason is needed)

Sounds good to me.

Comment 2 Fedora Update System 2009-07-18 22:04:42 UTC
php-pecl-json-1.2.1-4.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/php-pecl-json-1.2.1-4.el5

Comment 3 Jon Stanley 2009-07-19 22:12:11 UTC
Sorry for not commenting in the bug and just submitting an update against it :).  That update adds php-json to Provides :)

Comment 4 Fedora Update System 2009-07-20 16:56:54 UTC
php-pecl-json-1.2.1-4.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update php-pecl-json'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-5/FEDORA-EPEL-2009-0104

Comment 5 Fedora Update System 2009-08-05 17:23:05 UTC
php-pecl-json-1.2.1-4.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.