Bug 51235 - rpm doesn't create .rpmnew files when upgrading
rpm doesn't create .rpmnew files when upgrading
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-08 13:18 EDT by Need Real Name
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-08 13:18:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-08-08 13:18:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.7 i686; Nav)

Description of problem:
I have a chrooted build environment, made with RH 7.1 packages, including
rpm 4.0.2-8.
I did a minimal update to the new beta versions of: popt, rpm, glibc and
glibc-common

bash-2.04: rpm -Uvh popt-1.6.3-0.79.i386.rpm rpm-4.0.3-0.79.rpm
glibc-2.2.3-19.i386.rpm glibc-common-2.2.3-19.i386.rpm

Everything went fairly well until it did the actual 'rpm' upgrade.  Then,
it warned that it was making Basenames.rpmnew, Conflictname.rpmnew,
Group.rpmnew, Name.rpmnew, Packages.rpmnew Providename.rpmnew,
Requirename.rpmnew and Triggername.rpmnew

Unfortunately, those files weren't actually created.  rpm -q rpm  shows the
version as 4.0.3-0.79, and rpm -qa shows the correctly installed RPMs.

How reproducible:
Always

Steps to Reproduce:
1. Create a chrooted build environment with these packages:
filesystem, basesystem, mktemp, libtermcap, rootfiles, info, gawk, db1,
zlib, db2, diffutils, shadow-utils, gdbm, glibc-common, popt, setup,
termcap, bash, ncurses, fileutils, textutils, bzip2, db3, binutils, mount,
dev, perl, glibc, rpm.   [All from original 7.1 distribution, no updates)
with arguments:  -ivh --root=CHROOTDIR
2. chroot CHROOTDIR /bin/bash
3. rpm -Uvh popt-1.6.3-0.79.i386.rpm rpm-4.0.3-0.79.rpm
glibc-2.2.3-19.i386.rpm glibc-common-2.2.3-19.i386.rpm
4. /bin/ls -l /var/lib/rpm/*rpmnew
	

Actual Results:  All worked fine, got the warning messages stated in the
summary about creating the .rpmnew files in /var/lib/rpm/.
They aren't there.

Expected Results:  I'd expect to have them, since it warned me.  Either it
shouldn't warn me, or worse, it didn't create them. 

Additional info:

I can send a copy of the build environment .tgz file (pre-upgrade), it's
28mb, so a little larger than i'm comfortable with just attaching.
Comment 1 Jeff Johnson 2001-08-08 14:49:26 EDT
Yes, there's an error message, but no .rpmnew files, as these files are marked
%ghost. The error message will eventually be conditioned on %ghost correctly,
but, since %ghost semantics are still changing at the moment, there's
gonna be more than just the error message to fix. Deferred until then

Note You need to log in before you can comment on or make changes to this bug.