Bug 51237 - KDE 2.1.1 Update Bug
KDE 2.1.1 Update Bug
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-08 13:54 EDT by Need Real Name
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-08 14:06:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-08-08 13:54:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
I recently updated two Red Hat 7.0 machines from KDE 2.1 to KDE 2.1.1. 
Both times, when X restarted I was left with a prompt from 
the "desktopconv" program that it had found some 1.x files in ~/. It asks 
if you want delete them [recommended], or convert them, or ignore them. 
Both times I deleted them and was left with a clean desktop, everything 
had to be re-configured.

How reproducible:
Always

Steps to Reproduce:
1. Upgrade KDE with the 2.1.1 RPMs
2. Restart X
	

Expected Results:  It shouldn't have detected 1.x files, I have NEVER had 
1.x installed on my machines.

Additional info:
Comment 1 Bernhard Rosenkraenzer 2001-08-08 14:00:01 EDT
Umm... KDE 1.1.2 was shipped with 7.0, so if they're really 7.0 machines, you 
did have 1.x installed.
Were they 7.0 or 7.1 machines?
We never shipped 2.1, by the way. 7.0 had 1.1.2, 7.1 had 2.1.1.
Comment 2 Need Real Name 2001-08-08 14:06:18 EDT
As the message states, I was updating [via KDE's RPMs] from 2.1 to 2.1.1. There 
were 7.0 machines, for sure.

What I meant by nothing having 1.x installed was, I never actually used 1.x at 
all. From the first day of installation, I had only used KDE2 as the desktop 
for both machines.

HTH,
cS
Comment 3 Bernhard Rosenkraenzer 2001-08-08 14:17:58 EDT
So you did have 1.1.2 installed but never used it. That's quite a difference 
as far as config files are concerned.
The problem is that the 2.1 RPMs you used didn't do anything about the 1.1.2 
config files (should have removed them in the first place).

2.1.1 and higher are doing the right thing by removing .kde if they're 
detecting you're upgrading from 1.x (which they're detecting by the presence of 
the obsolete kpanelrc file).

If you want to avoid this on other similar setups, remove 
.kde/share/config/kpanelrc before starting 2.1.1 or 2.2 for the first time.

Closing as CURRENTRELEASE because the problem is with the 2.1 packages. (And 
fixing those now wouldn't make any sense - at least I don't see any reason why 
someone would want to install 2.1 now that 2.1.1 and 2.2 are out.)

Note You need to log in before you can comment on or make changes to this bug.