Bug 512373 - [LTC 5.5 FEAT] Add drmgr and lsslot to DLPAR tools package [201962]
[LTC 5.5 FEAT] Add drmgr and lsslot to DLPAR tools package [201962]
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ppc64-utils (Show other bugs)
5.5
ppc64 All
high Severity high
: beta
: 5.5
Assigned To: Roman Rakus
Alexander Todorov
: FutureFeature, OtherQA, Rebase
Depends On:
Blocks: 533941 557292 481160 525706 5.5TechNotes-Updates
  Show dependency treegraph
 
Reported: 2009-07-17 11:01 EDT by IBM Bug Proxy
Modified: 2014-01-12 19:09 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
This is pure future feature enhancement. Link for changelog: http://powerpc-utils.git.sourceforge.net/git/gitweb.cgi?p=powerpc-utils/powerpc-utils;a=blob;f=Changelog;h=592d3e8aac2e8ded4122f7b156f8713783ae8607;hb=HEAD
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 04:19:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 54856 None None None Never

  None (edit)
Description IBM Bug Proxy 2009-07-17 11:01:47 EDT
=Comment: #0=================================================
Emily J. Ratliff <ratliff@austin.ibm.com> - 
1. Feature Overview:
Feature Id:	[201962]
a. Name of Feature:	Add drmgr and lsslot to DLPAR tools package
b. Feature Description
The ppc64-utils package included in RHEL 5.4 does not include drmgr or lsslot. lsslot provides
system configuration data to the user. drmgr is required to perform DLPAR operations.

2. Feature Details:
Sponsor:	PPC - P
Architectures:
ppc64

Arch Specificity: Purely Arch Specific Code
Delivery Mechanism: Direct from community
Category:	Power Virtualization
Request Type:	Package - Version Update
d. Upstream Acceptance:	Accepted
Sponsor Priority	
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	

3. Business Case
DLPAR is a common virtualization feature on the Power platform. Customers wanting DLPAR support
today, must first remove the ppc64-utils package before installing the powerpc-utils package from an
IBM site, since the packages conflict. Adding this support to ppc64-utils will remove this
requirement and make it much easier for a Power customer to use DLPAR with Linux.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Mike Wortman, wortman@us.ibm.com

Technical contact(s):
Nathan Fontenot, nfonteno@us.ibm.com

IBM Manager:
Alexander Johnson, acjohnso@us.ibm.com
Comment 2 IBM Bug Proxy 2009-09-21 12:10:25 EDT
------- Comment From nfont@austin.ibm.com 2009-09-21 12:08 EDT-------
The latest version of powerpc-utils (v1.2.1) is available at powerpc-utils.sourceforge.net, or you can download a tarball directly at  http://downloads.sourceforge.net/project/powerpc-utils/powerpc-utils-1.2.1.tar.gz.
Comment 4 Chris Ward 2009-10-23 10:05:39 EDT
@IBM

We need to confirm that there is commitment to test 
for the resolution of this request during the RHEL 5.5 Test
Phase, if it is accepted into the release.

RHEL 5.5 Beta Test Phase is expected to begin around February
2010.

Please post a confirmation as soon as possible, 
including the contact information for testing engineers.
Comment 6 John Jarvis 2009-10-23 11:08:11 EDT
IBM is signed up to test and provide feedback.
Comment 8 Roman Rakus 2009-10-27 11:04:51 EDT
IBM, is your proposed change also in upstream? I don't see it at http://powerpc-utils.ozlabs.org/
Comment 9 IBM Bug Proxy 2009-10-27 12:31:07 EDT
------- Comment From brking@us.ibm.com 2009-10-27 12:20 EDT-------
(In reply to comment #8)
> IBM, is your proposed change also in upstream? I don't see it at
> http://powerpc-utils.ozlabs.org/

The powerpc-utils package has moved to sourceforge. The updated package is available here:

http://sourceforge.net/projects/powerpc-utils/
Comment 10 Roman Rakus 2009-10-29 08:53:49 EDT
I see, thanks.
Comment 12 John Jarvis 2009-10-29 12:29:30 EDT
This enhancement request was evaluated by the full Red Hat Enterprise Linux 
team for inclusion in a Red Hat Enterprise Linux minor release.   As a 
result of this evaluation, Red Hat has tentatively approved inclusion of 
this feature in the next Red Hat Enterprise Linux Update minor release.   
While it is a goal to include this enhancement in the next minor release 
of Red Hat Enterprise Linux, the enhancement is not yet committed for 
inclusion in the next minor release pending the next phase of actual 
code integration and successful Red Hat and partner testing.
Comment 13 Roman Rakus 2009-12-08 09:11:30 EST
Fixed in ppc64-utils-0.11-13.el5
Comment 16 Roman Rakus 2009-12-08 09:54:25 EST
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
This is pure future feature enhancement.
Link for changelog: http://powerpc-utils.git.sourceforge.net/git/gitweb.cgi?p=powerpc-utils/powerpc-utils;a=blob;f=Changelog;h=592d3e8aac2e8ded4122f7b156f8713783ae8607;hb=HEAD
Comment 17 IBM Bug Proxy 2010-02-10 12:01:17 EST
------- Comment From brking@us.ibm.com 2010-02-10 11:55 EDT-------
Verified in RHEL 5.5 Beta.
Comment 18 Alexander Todorov 2010-02-17 08:23:34 EST
moving to VERIFIED as per comment #17
Comment 21 errata-xmlrpc 2010-03-30 04:19:36 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0225.html
Comment 22 IBM Bug Proxy 2010-04-08 10:41:00 EDT
------- Comment From rlary@us.ibm.com 2010-04-08 10:39 EDT-------
Fixed in Red Hat errata:

Note You need to log in before you can comment on or make changes to this bug.