Bug 51244 - X Window System (XFree) fails to display correct colors and resolution using a Creative Exxtreme video card (Permedia 2)
X Window System (XFree) fails to display correct colors and resolution using ...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-08 14:34 EDT by Jorge Perez
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-08 14:34:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jorge Perez 2001-08-08 14:34:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90)

Description of problem:
When installing Red Hat Linux 7.1 (seaworf) the installer shows fuzzy 
colors (all messy) only after doing a test with 24 bit color and 640x480 
resolution the color table seems to work, but if you choose 1024x768 @ 
24/16 bit color, the system shows a big mess.
Seems to be a problem with XFree packed with Linux 7.1

How reproducible:
Always

Steps to Reproduce:
1. Turno off machine, insert RHL 7.1 disc 1
2. Wait after the (loading anaconda) and (starting the X system) shows
3. Look at the screen, a dark brown (red) screen with the RHL logo and the 
edges in bright red, click next to start the install and the screen still 
shows everything in dark brown (red) gray and black, with some light blue 
flases
4. Complete the installation (choose a 1024x768 resolution with 24b or 16 
b color) finish the install.. boot your box... tadaaa fuzzy colors and 
messy things will appear.
	

Actual Results:  Wrong colors showing (making the screen unreadable)
No Hi Res color available
the only "good" mode is 640x480 @ 16 bit

Expected Results:  The Crative Labs Exxtreme card ( a permmedia 2 card) is 
able to display 16/24 bit colors at a res of 1024 x 768 (I have the same 
type of video card working under Red Hat Linux 6.2 and works just fine)

Additional info:

I tried both drvers:
Creative Labs Exxtreme
and the Generic
3D Labs permedia 2
both of them FAIL!
Comment 1 Mike A. Harris 2001-08-10 15:20:07 EDT
Various bugs in permedia support were fixed in post 7.1 unofficial
4.0.3 updates on my ftp space at people.redhat.com.  These fixes
are included now in the official packages in rawhide for XFree86 4.1.0.

There will be a errata release for Red Hat Linux 7.1 at some
unknown point in time in the future.  For the time being, you can
try the 4.1.0 packages in rawhide if you wish.

Note You need to log in before you can comment on or make changes to this bug.