Bug 51247 - sendmail-8.10.0-aliasesDoS.patch should NOT be included
sendmail-8.10.0-aliasesDoS.patch should NOT be included
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: sendmail (Show other bugs)
roswell
All Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-08 14:57 EDT by Christopher McCrory
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-08 15:02:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher McCrory 2001-08-08 14:57:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010725

Description of problem:
sendmail-8.10.0-aliasesDoS.patch should NOT be included

attaching emails from claus

How reproducible:
Always

Steps to Reproduce:
1.  rpm --rebuild sendmail-8...
2.
3.
	

Additional info:
Comment 1 Christopher McCrory 2001-08-08 15:02:48 EDT
This was originally from a sendmail 8.12.0 Beta build, but applies to current rpm



From Claus (@sendmail Inc.)

<snip>
> 
> [chrismcc@www1 sendmail-8.12.0.Beta7]$ head -n 1030 sendmail/main.c | 
> tail -n 7
> 
> if (LogLevel > 1)
> sm_syslog(LOG_ALERT, NOQID,
> "user %d attempted to rebuild the alias map",
> RealUid);
> usrerr("Permission denied");
> finis(FALSE, EX_USAGE);
> }


Where did you get that version? Did you patch it? That's NOT in
the version we distribute (I just verified it twice).  Please
download Beta7 from sendmail.org and verify the PGP signature.


-----
On Thu, May 24, 2001, Christopher McCrory wrote:


> > Where did you get that version? Did you patch it? That's NOT in
> > the version we distribute (I just verified it twice).  Please
> > download Beta7 from sendmail.org and verify the PGP signature.

> 
> 
> You're right.  Sorry.  It was from a aliases DOS attack patch for older 
> sendmail versions that I accidently left in place.


That code is in sendmail since 8.10.

------  END -----

I can send/attach more emails if you would like.


Comment 2 Florian La Roche 2001-08-09 08:14:24 EDT
Thanks a lot for this bug-report, fixed in next release,

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.