This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 512504 - syntaxError: invalid syntax File "/usr/lib64/python2.6/site-packages/FontTools/fontTools/ttLib/tables/ttProgram.py", line 397 as = p.getAssembly()
syntaxError: invalid syntax File "/usr/lib64/python2.6/site-packages/FontTool...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: fonttools (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Roozbeh Pournader
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-07-18 04:38 EDT by Nicolas Mailhot
Modified: 2010-07-29 01:50 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-29 01:50:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
simple patch to fix this (289 bytes, patch)
2009-09-29 23:06 EDT, Akira TAGOH
no flags Details | Diff

  None (edit)
Description Nicolas Mailhot 2009-07-18 04:38:52 EDT
Description of problem:

While building latest heuristica snapshot

rm Heuristica-Regular.gen.ttx
rm: cannot remove `Heuristica-Regular.gen.ttx': No such file or directory
ttx Heuristica-Regular.gen.ttf
make: [Heuristica-Regular.gen.ttx] Error 1 (ignored)
Dumping "Heuristica-Regular.gen.ttf" to "Heuristica-Regular.gen.ttx"...
Dumping 'GlyphOrder' table...
Dumping 'head' table...
Dumping 'hhea' table...
Dumping 'maxp' table...
Dumping 'OS/2' table...
Dumping 'hmtx' table...
Dumping 'cmap' table...
Traceback (most recent call last):
  File "/usr/bin/ttx", line 11, in <module>
    ttx.main(sys.argv[1:])
  File "/usr/lib64/python2.6/site-packages/FontTools/fontTools/ttx.py", line 288, in main
    process(jobs, options)
  File "/usr/lib64/python2.6/site-packages/FontTools/fontTools/ttx.py", line 273, in process
    action(input, output, options)
  File "/usr/lib64/python2.6/site-packages/FontTools/fontTools/ttx.py", line 170, in ttDump
    disassembleInstructions=options.disassembleInstructions)
  File "/usr/lib64/python2.6/site-packages/FontTools/fontTools/ttLib/__init__.py", line 267, in saveXML
    self._tableToXML(tableWriter, tag, progress)
  File "/usr/lib64/python2.6/site-packages/FontTools/fontTools/ttLib/__init__.py", line 282, in _tableToXML
    table = self[tag]
  File "/usr/lib64/python2.6/site-packages/FontTools/fontTools/ttLib/__init__.py", line 366, in __getitem__
    tableClass = getTableClass(tag)
  File "/usr/lib64/python2.6/site-packages/FontTools/fontTools/ttLib/__init__.py", line 774, in getTableClass
    module = getTableModule(tag)
  File "/usr/lib64/python2.6/site-packages/FontTools/fontTools/ttLib/__init__.py", line 763, in getTableModule
    __import__("fontTools.ttLib.tables." + pyTag)
  File "/usr/lib64/python2.6/site-packages/FontTools/fontTools/ttLib/tables/_f_p_g_m.py", line 3, in <module>
    import ttProgram
  File "/usr/lib64/python2.6/site-packages/FontTools/fontTools/ttLib/tables/ttProgram.py", line 397
    as = p.getAssembly()
     ^
SyntaxError: invalid syntax
make: *** [Heuristica-Regular.gen.ttx] Error 1
make: *** Waiting for unfinished jobs....

Version-Release number of selected component (if applicable):

fonttools           x86_64 2.2-5.fc11
Comment 1 Akira TAGOH 2009-09-29 23:06:40 EDT
Created attachment 363113 [details]
simple patch to fix this

I see the same issue with ttx. just attached a simple patch. modified ttx works fine for me.
Comment 2 M.R. Beauchamp 2010-01-16 18:47:47 EST
The patch works for me, too. Now we need packages to fix ttx.
Comment 3 Bug Zapper 2010-03-15 08:42:43 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Parag Nemade 2010-07-29 01:50:22 EDT
This looks fixed long ago

Note You need to log in before you can comment on or make changes to this bug.