Bug 512570 - gnome-panel segfaults
gnome-panel segfaults
Status: CLOSED DUPLICATE of bug 512078
Product: Fedora
Classification: Fedora
Component: prelink (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-07-19 06:52 EDT by Nicolas Mailhot
Modified: 2009-07-20 19:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-20 19:53:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2009-07-19 06:52:36 EDT
Description of problem:


$ gdb gnome-panel
GNU gdb (GDB) Fedora (6.8.50.20090302-39.fc12)
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
(gdb) run
Starting program: /usr/bin/gnome-panel 

Program received signal SIGSEGV, Segmentation fault.
0x000000344007ecab in ?? ()
(gdb) bt
#0  0x000000344007ecab in ?? ()
#1  0x000000343fc10dab in elf_machine_rela (reloc_addr_arg=<value optimized out>, version=<value optimized out>, sym=<value optimized out>, 
    reloc=<value optimized out>, map=<value optimized out>) at ../sysdeps/x86_64/dl-machine.h:448
#2  _dl_resolve_conflicts (reloc_addr_arg=<value optimized out>, version=<value optimized out>, sym=<value optimized out>, reloc=<value optimized out>, 
    map=<value optimized out>) at dl-conflict.c:72
#3  0x000000343fc02830 in ?? () at rtld.c:752 from /lib64/ld-linux-x86-64.so.2
#4  0x0000003df3265828 in ?? ()
#5  0x00007ffff7fc5000 in ?? ()
#6  0x00007ffff7ffd000 in ?? ()
#7  0x00007fffffffe1b0 in ?? ()
#8  0x0000000000000001 in ?? ()
#9  0x000000000003981b in ?? ()
#10 0x00000000818d4440 in ?? ()
#11 0x00007ffff7fc5800 in ?? ()
#12 0x000000343fc03b1d in dl_main (phdr=<value optimized out>, phnum=<value optimized out>, user_entry=<value optimized out>) at rtld.c:2167
#13 0x0000000000000000 in ?? ()

Version-Release number of selected component (if applicable):

gnome-panel-2.27.4-1.fc12.x86_64

atk-debuginfo-1.25.2-2.fc11.x86_64
cairo-debuginfo-1.8.8-1.fc12.x86_64
dbus-debuginfo-1.2.16-1.fc12.x86_64
dbus-glib-debuginfo-0.80-3.fc12.x86_64
evolution-data-server-debuginfo-2.27.4-1.fc12.x86_64
fontconfig-debuginfo-2.7.0-1.fc12.x86_64
freetype-debuginfo-2.3.9-4.fc12.x86_64
GConf2-debuginfo-2.26.2-3.fc12.x86_64
glib2-debuginfo-2.21.4-1.fc12.x86_64
glibc-debuginfo-2.10.90-3.x86_64
gnome-desktop-debuginfo-2.27.4-1.fc12.x86_64
gnome-menus-debuginfo-2.27.4-1.fc12.x86_64
gnome-panel-debuginfo-2.27.4-1.fc12.x86_64
gnome-vfs2-debuginfo-2.24.1-3.fc12.x86_64
gtk2-debuginfo-2.17.5-1.fc12.x86_64
libart_lgpl-debuginfo-2.3.20-4.fc11.x86_64
libbonobo-debuginfo-2.24.1-2.fc12.x86_64
libbonoboui-debuginfo-2.24.1-1.fc11.x86_64
libglade2-debuginfo-2.6.4-2.fc12.x86_64
libgnomecanvas-debuginfo-2.26.0-1.fc11.x86_64
libgnome-debuginfo-2.26.0-3.fc12.x86_64
libgnomeui-debuginfo-2.24.1-1.fc11.x86_64
libgweather-debuginfo-2.26.1-3.fc12.x86_64
libical-debuginfo-0.43-4.fc11.x86_64
libICE-debuginfo-1.0.4-7.fc11.x86_64
librsvg2-debuginfo-2.26.0-1.fc11.x86_64
libSM-debuginfo-1.1.0-4.fc11.x86_64
libsoup-debuginfo-2.27.4-1.fc12.x86_64
libwnck-debuginfo-2.27.4-1.fc12.x86_64
libX11-debuginfo-1.2.99-1.20090712.fc12.x86_64
libXau-debuginfo-1.0.4-5.fc11.x86_64
libxml2-debuginfo-2.7.3-2.fc11.x86_64
ORBit2-debuginfo-2.14.17-1.fc11.x86_64
pango-debuginfo-1.24.4-1.fc12.x86_64
polkit-debuginfo-0.92-3.fc12.x86_64
popt-debuginfo-1.13-5.fc12.x86_64
startup-notification-debuginfo-0.10-1.fc12.x86_64
Comment 1 Nicolas Mailhot 2009-07-19 07:04:31 EDT
On a whim I tried a /usr/sbin/prelink -uav and that solved the problem

Reassigning to prelink

prelink-0.4.2-1.fc12.x86_64
Comment 2 Matthias Clasen 2009-07-20 19:53:32 EDT

*** This bug has been marked as a duplicate of bug 512078 ***

Note You need to log in before you can comment on or make changes to this bug.