Bug 512598 - xine-ui can't find its help files
Summary: xine-ui can't find its help files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xine-ui
Version: 11
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Susi Lehtola
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-07-19 17:59 UTC by Edward Sheldrake
Modified: 2009-08-20 20:55 UTC (History)
1 user (show)

Fixed In Version: 0.99.5-15.fc10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-20 20:52:45 UTC
Type: ---


Attachments (Terms of Use)
change doc encoding to UTF-8 (542 bytes, patch)
2009-07-19 18:02 UTC, Edward Sheldrake
no flags Details | Diff

Description Edward Sheldrake 2009-07-19 17:59:33 UTC
Description of problem:
xine-ui can't find its help files.

Version-Release number of selected component (if applicable):
xine-ui-0.99.5-11.fc11

How reproducible:
Always.

Steps to Reproduce:
1. Start xine.
2. Right-click the output window and choose Help from the menu.
3.
  
Actual results:
An error dialog "Cannot open help files: No such file or directory"

Expected results:
A tabbed dialog displaying the help files.

Additional info:
This can be easily fixed by not deleting xine's help files and then installing them somewhere else. If you want to change where xine puts the help files, pass XINE_DOCPATH=dir to configure. The only files suitable for the %doc macro appear to be ChangeLog COPYING and README.xitk (after mv %{buildroot}%{_docdir}/xitk/README README.xitk in %install).

Comment 1 Edward Sheldrake 2009-07-19 18:02:38 UTC
Created attachment 354277 [details]
change doc encoding to UTF-8

Also, since the .spec file converts all the help files to UTF-8, I guess the xine code should be changed to load them as UTF-8.

Comment 2 Fedora Update System 2009-07-19 23:47:11 UTC
xine-ui-0.99.5-13.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/xine-ui-0.99.5-13.fc11

Comment 3 Fedora Update System 2009-07-19 23:47:30 UTC
xine-ui-0.99.5-13.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/xine-ui-0.99.5-13.fc10

Comment 4 Fedora Update System 2009-07-22 21:49:22 UTC
xine-ui-0.99.5-13.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xine-ui'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-7848

Comment 5 Susi Lehtola 2009-07-22 21:58:51 UTC
Thanks for the patch. The new release should have fixed the problem.

Comment 6 Fedora Update System 2009-07-22 22:02:43 UTC
xine-ui-0.99.5-13.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xine-ui'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7897

Comment 7 Fedora Update System 2009-07-24 21:39:50 UTC
xine-ui-0.99.5-15.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/xine-ui-0.99.5-15.fc10

Comment 8 Fedora Update System 2009-07-24 21:41:33 UTC
xine-ui-0.99.5-15.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/xine-ui-0.99.5-15.fc11

Comment 9 Fedora Update System 2009-07-27 21:36:37 UTC
xine-ui-0.99.5-15.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xine-ui'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8038

Comment 10 Fedora Update System 2009-07-27 21:40:12 UTC
xine-ui-0.99.5-15.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xine-ui'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-8055

Comment 11 Fedora Update System 2009-08-20 20:52:36 UTC
xine-ui-0.99.5-15.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2009-08-20 20:54:58 UTC
xine-ui-0.99.5-15.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.