Bug 512604 - Request to bring back xine-skins package
Summary: Request to bring back xine-skins package
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xine-ui
Version: 11
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Susi Lehtola
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-07-19 19:14 UTC by W Agtail
Modified: 2009-08-20 20:55 UTC (History)
1 user (show)

Fixed In Version: 0.99.5-15.fc10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-20 20:52:50 UTC
Type: ---


Attachments (Terms of Use)

Description W Agtail 2009-07-19 19:14:37 UTC
Description of problem:
xine-skins package appears to be no longer available for xine in Fedora 11.
I have searched Fedora & Fusion repos.

Version-Release number of selected component (if applicable):
Fedora 11

How reproducible:
Always

Steps to Reproduce:
1. yum install xine-skins
2.
3.
  
Actual results:
No package xine-skins available.

Expected results:
Installation od xine-skins rpm.

Additional info:

Comment 1 Fedora Update System 2009-07-19 23:47:15 UTC
xine-ui-0.99.5-13.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/xine-ui-0.99.5-13.fc11

Comment 2 Fedora Update System 2009-07-19 23:47:34 UTC
xine-ui-0.99.5-13.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/xine-ui-0.99.5-13.fc10

Comment 3 Fedora Update System 2009-07-22 21:49:27 UTC
xine-ui-0.99.5-13.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xine-ui'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-7848

Comment 4 Susi Lehtola 2009-07-22 21:59:43 UTC
Thanks for the report, the new release should have fixed the problem.

(You need to run # yum --enablerepo=updates-testing install xine-ui-skins )

Comment 5 Fedora Update System 2009-07-22 22:02:47 UTC
xine-ui-0.99.5-13.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xine-ui'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7897

Comment 6 W Agtail 2009-07-24 16:57:34 UTC
Thank you for the update.
I have updated as instructed (see below) and now I see the following when starting xine:
This is xine (X11 gui) - a free video player v0.99.5.
(c) 2000-2007 The xine Team.
xiTK WARNING(xitk_image_load_image:1646): xitk_image_load_image(): couldn't find image /usr/share/xine/skins/xine_splash.png
[WARN 23577] polkit-session.c:144:polkit_session_set_uid(): session != NULL
 Not built with -rdynamic so unable to print a backtrace

There is still no evidence of additional skins in the new xine-ui-0.99.5-13.fc11.x86_64 RPM, only the default xinetic skin.

Kind regards.

### output from yum update command ###
yum --enablerepo=updates-testing update xine-ui
Loaded plugins: refresh-packagekit
updates-testing/metalink                                                                             | 8.9 kB     00:00     
updates-testing                                                                                      | 4.4 kB     00:00     
updates-testing/primary_db                                                                           | 984 kB     00:02     
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package xine-ui.x86_64 0:0.99.5-13.fc11 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

============================================================================================================================
 Package                  Arch                    Version                            Repository                        Size
============================================================================================================================
Updating:
 xine-ui                  x86_64                  0.99.5-13.fc11                     updates-testing                  1.5 M

Transaction Summary
============================================================================================================================
Install      0 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total download size: 1.5 M
Downloading Packages:
xine-ui-0.99.5-13.fc11.x86_64.rpm                                                                    | 1.5 MB     00:03     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating       : xine-ui-0.99.5-13.fc11.x86_64                                                                        1/2 
  Cleanup        : xine-ui-0.99.5-11.fc11.x86_64                                                                        2/2 

Updated:
  xine-ui.x86_64 0:0.99.5-13.fc11                                                                                           

Complete!

Comment 7 Susi Lehtola 2009-07-24 20:31:08 UTC
(In reply to comment #4)
> Thanks for the report, the new release should have fixed the problem.
> 
> (You need to run # yum --enablerepo=updates-testing install xine-ui-skins )  

You need to run the command above to install the skins.

I can't reproduce the error you get
 xiTK WARNING(xitk_image_load_image:1646): xitk_image_load_image(): couldn't
 find image /usr/share/xine/skins/xine_splash.png
there must be something wrong with your config file.

Comment 8 W Agtail 2009-07-24 21:07:38 UTC
Hi
Thanks again for your advice.
I have installed xine-ui-skins and I am able to select different skins.

I am not sure if this is a valid test, but I am able to reproduce the error message by doing the following:

rpm -e xine-ui-skins
cd; rm -rf .xine
xine

and then the error appears:
xiTK WARNING(xitk_image_load_image:1646): xitk_image_load_image(): couldn't find image /usr/share/xine/skins/xine_splash.png

Looks like this is set in the xine-ui and /usr/share/xine/skins/xine_splash.png is part of the xine-ui-skins RPM.

Regards

Comment 9 Susi Lehtola 2009-07-24 21:16:20 UTC
(In reply to comment #8)
> Looks like this is set in the xine-ui and /usr/share/xine/skins/xine_splash.png
> is part of the xine-ui-skins RPM.

Duh. Thanks. That was a packaging mishap on my behalf. Fixed in the next revision.

Comment 10 Fedora Update System 2009-07-24 21:39:54 UTC
xine-ui-0.99.5-15.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/xine-ui-0.99.5-15.fc10

Comment 11 Fedora Update System 2009-07-24 21:41:37 UTC
xine-ui-0.99.5-15.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/xine-ui-0.99.5-15.fc11

Comment 12 Fedora Update System 2009-07-27 21:36:42 UTC
xine-ui-0.99.5-15.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xine-ui'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8038

Comment 13 Fedora Update System 2009-07-27 21:40:16 UTC
xine-ui-0.99.5-15.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xine-ui'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-8055

Comment 14 W Agtail 2009-07-28 16:39:43 UTC
Thankyou for the new update.
There still appears to be a slight issue with xine-ui.
In the default ~/.xine/config file, xine-ui_logo.mpv is referenced, which is not available in the xine-ui RPM.

:> grep mpv ~/.xine/config 
# string, default: file:/usr/share/xine/skins/xine-ui_logo.mpv
#gui.logo_mrl:file:/usr/share/xine/skins/xine-ui_logo.mpv

:> ls /usr/share/xine/skins/
xine_splash.png  xinetic

After playing a file with xine, a couple of error messages are displayed.
/usr/share/xine/skins/xine-ui_logo.mpv is only available in xine-ui-skins.

Other than this, all seems good.

Regards.

Comment 15 Fedora Update System 2009-08-20 20:52:41 UTC
xine-ui-0.99.5-15.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2009-08-20 20:55:03 UTC
xine-ui-0.99.5-15.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.