Bug 512616 - squid wakes up the CPU when doing nothing
squid wakes up the CPU when doing nothing
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: squid (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Jiri Skala
Fedora Extras Quality Assurance
http://www.squid-cache.org/bugs/show_...
: Upstream
Depends On:
Blocks: wakeup
  Show dependency treegraph
 
Reported: 2009-07-19 16:57 EDT by Edwin ten Brink
Modified: 2014-11-09 17:31 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 03:17:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edwin ten Brink 2009-07-19 16:57:35 EDT
Description of problem:
Even without any connected clients, squid wakes up the CPU 100 times per second according to powertop. This does not seem necessary.


Version-Release number of selected component (if applicable):
$ rpm -q squid
squid-3.0.STABLE15-2.fc11.i586
Comment 1 David Rees 2009-07-20 14:00:26 EDT
Confirmed here, also affects F10 since it has the same version of squid.  Powertop reports this:

  12.3% (100.8)             squid : __mod_timer (process_timeout)

Stracing squid shows this going on 100 times a second:

epoll_wait(6, {}, 16384, 10)            = 0
Comment 2 Henrik Nordström 2009-07-20 15:56:58 EDT
Upstream are aware of this. Don't remember right now why it needed to do this other than that it's a workaround for a timing race and that it is not likely to be fixed in 3.0.

3.1 will behave better and will be available in F-12.
Comment 3 Edwin ten Brink 2009-07-21 15:38:10 EDT
(In reply to comment #2)
Found your original posting on squid-users mailing list in October 2008:
http://www.squid-cache.org/mail-archive/squid-users/200810/0158.html

(In reply to comment #1)
David, you seem to be right about the polling:
http://www.squid-cache.org/mail-archive/squid-users/200810/0148.html
Comment 4 Henrik Nordström 2009-07-21 16:02:26 EDT
The polling is a red herring (just an effect, not the cause), the issue is elsewhere, with the polling just plastering over it..

Linked to upstream bug report (closed).
Comment 5 Edwin ten Brink 2009-07-22 03:17:24 EDT
(In reply to comment #4)
> Linked to upstream bug report (closed).  

Ok, thanks. Let's close this one for now then with CLOSED - NEXTRELEASE (squid 3.1) as it appears to have been resolved indeed from the bug report at http://www.squid-cache.org/bugs/show_bug.cgi?id=2011

Note You need to log in before you can comment on or make changes to this bug.