Bug 51269 - [PATCH] DMI blacklist for Dell servers
Summary: [PATCH] DMI blacklist for Dell servers
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-08 21:00 UTC by Matt Domsch
Modified: 2007-04-18 16:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-04 18:07:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmi_scan-fix.patch (2.98 KB, patch)
2001-08-08 21:03 UTC, Matt Domsch
no flags Details | Diff

Description Matt Domsch 2001-08-08 21:00:51 UTC
Patch changes entries in the DMI blacklist, and adds a couple functions 
they need.  PowerEdge 1300 needs only one entry (/500 and /550 are CPU 
speeds).  PowerEdge 300 needs name change there.  functions set_smp_reboot
() and set_smp_bios_reboot() added and called as necessary.  reboot_smp 
made non-static as it's needed across .c files.    Removed unnecessary and 
broken test for monotonically increasing DMI table entry types.

Comment 1 Matt Domsch 2001-08-08 21:03:42 UTC
Created attachment 26894 [details]
dmi_scan-fix.patch

Comment 2 Arjan van de Ven 2001-08-09 09:52:34 UTC
added to kernel 2.4.7-0.12 and later.


Comment 3 John A. Hull 2001-09-04 18:07:22 UTC
DMA is still enabled in RC2 on /dev/cdrom.

Comment 4 Michael K. Johnson 2001-09-06 15:18:54 UTC
This bug report had nothing to do with DMA on cdroms.  It had to do
with rebooting certain machines.

We know about and have fixed other DMA problems since RC2.


Note You need to log in before you can comment on or make changes to this bug.