Bug 5127 - knfsd 1.4.7 working with kernel 2.2.5-22
Summary: knfsd 1.4.7 working with kernel 2.2.5-22
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: knfsd   
(Show other bugs)
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-14 14:35 UTC by Felicia
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-19 18:44:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Felicia 1999-09-14 14:35:01 UTC
This was originally an email support ticket.  We recommended
that he upgrade to the knfsd 1.4.7 rather than using
1.2.2-4.  Final email from customer states:

As of now, I can run my nfs server correctly under 2.2.5-22
if, and only if, I install the knfsd 1.2.2-4 rpm's after
installing the kernel rpm. (I'm guessing that I couldn't get
this to work earlier because the sequence of rpm's may be
critical.) However, if I install the knfsd 1.4.7-2 rpm's in
that same sequence instead of 1.2.2-4, I get the error

     mount: RPC: Program not registered

It looks like NFS support should be expected to be pretty
tenuous for now. But at least I can finally get something.

Comment 1 Jeff Johnson 1999-09-19 18:44:59 UTC
There are knfsd version specific patches in the kernel, so you need to
upgrade both the kernel and knfsd simultaneously. AFAIK, the latest
kernel in Raw Hide has the patches for the latest knfsd in Raw Hide.


Note You need to log in before you can comment on or make changes to this bug.