Bug 51279 - Red Hat 7.1 Installer hangs when booting linux
Red Hat 7.1 Installer hangs when booting linux
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-08 19:43 EDT by John Klingler
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 12:40:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Klingler 2001-08-08 19:43:05 EDT
Description of Problem:
    	    Red Hat 7.1 Installer hangs when "booting linux" from CD. 
    	    No messages are seen after that. I tried all modes (X, text, 
	    expert, linux dd, nofb, linux noprobe, linux nodma)


How Reproducible:	Every time


Steps to Reproduce:
1. Insert Red Hat 7.1 CD #1
2. boot
3. at Installer "boot:" prompt, press Enter or enter any option

Actual Results:
    	    In text mode, the system stops after the message "Booting 
	    Linux". The hexleds display "80".

	    In default mode, screen goes black before that and hexleds 
	    display "20".

Expected Results:
	    ...

Additional Information:
	    Running dual Pentium III w/440BX chipset. SCSI BIOS is Adaptec
	    AIC-7880 v2.10. The motherboard design for the AIC-7880 chipset
	    was cloned from the AHA-2940UW PCI SCSI controller.

	    We suspect the problem is in the aic7xxx driver since we had
	    problems with that on RH6.2. In this case, that is just a guess
	    since at least we were able to install RH6.2. 

	    The aic7xxx.c code for RH7.1 is vastly different from RH7.0.
Comment 1 Brent Fox 2001-08-09 23:19:09 EDT
This is a kernel problem.  You might also take a look at
http://www.redhat.com/support/docs/gotchas/7.1/gotchas-71.html, which has some
information about the aic7xxx driver. 

Changing component
Comment 2 Matt Wilson 2001-08-09 23:23:31 EDT
this is a BIOS or hardware problem, the kernel hasn't even been started yet, so
no amount of change in aic7xxx will make a difference.  Make sure you have the
latest SCSI BIOS installed.
Comment 3 John Klingler 2001-08-10 14:20:40 EDT
Red Hat 7.0 Installs and runs fine with the Adaptec aic7880 SCSI BIOS
v2.10, which is what we have, and the aic7xxx driver installed by Red
Hat. I would tend also to think it is a problem with the 7.1 kernel.
Here is the precise place the 7.1 Installer hangs:
	    boot: expert
	    Loading initrd.img..............................................
	    Loading vmlinuz..................... ready.
	    Uncompressing Linux... Ok, booting the kernel.

The aic7xxx bug reports all got error messages identifying the aic7xxx
as the problem. We do not. Some users were able to eliminate the hang 
by using the "noprobe" option. Both "expert" and "linux noprobe" are
supposed to disable PCI probe and allow selection of a driver, as is
"linux dd". Using these options, Installer still hangs. 

How can the SCSI BIOS or the aic7xxx driver be causing the hang?
Comment 4 John Klingler 2001-08-14 19:57:42 EDT
Red Hat 7.2 Beta installer and aic7xxx driver work fine.
Comment 5 Arjan van de Ven 2001-08-15 05:45:03 EDT
Ok call me puzzled as the beta has the same aic7xxx driver..
Comment 6 John Klingler 2001-08-15 14:21:41 EDT
The installer was hanging every time in the initial boot immediately
after the message "Ok, booting the kernel" before it even outputs 
the message that it is loading the aic7xxx driver, so that was 
probably not the problem. Using the "noprobe" option supposedly 
keeps the installer from probing the PCI bus, so presumeably the
SCSI BIOS was not the problem either, but who knows?

One thing is certain, the 7.1 installer was hanging every time and 
7.2 does not. Perhaps you should go look at the code and see what
is different. There is little point in having a theoretical argument. 


Note You need to log in before you can comment on or make changes to this bug.