Bug 51287 - Unable to connect to Internet using 8139too card and dhcp router
Unable to connect to Internet using 8139too card and dhcp router
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-network (Show other bugs)
roswell
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-08 21:11 EDT by nboric
Modified: 2008-05-01 11:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-09 17:08:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nboric 2001-08-08 21:11:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [es] (X11; U; Linux 2.4.3-12 i686)

Description of problem:
Note: I'm not sure if this problem is really related to the selecte package

I have to connect to a router that uses dhcp
All I did to set this up on rh 7.1 was:

(1) add "alias eth0 8139too" to modules.conf
(2) modprobe 8139too
(3) run netcfg and set eth0 to be automatically configured using dhcp
(4) ifup eth0

On roswell, I used redhat-config-network, added my card, the eth0
interface, the alias, etc.
Then I type ifup eth0 and it respodes "Unable to assing specified address"
by looking at /etc/sysconfig/networking/devices/ifcfg-eth0 it says

BOOTPROTO=DHCP
DEVICE=eth0:0
TYPE=Ethernet
ONBOOT=no
USERCTL=yes
PEERDNS=yes

I changed "eth0:0" to "eth0" and now when running ifup it seems to connect,
but doesn't actually look for an ip, and when I try to ping anything I get
"Network Unreachable"
Then I changed "DHCP" to "dhcp", and now it looks for an ip, but responds
"Cannot find link, check cable"
Well, I know the cable is ok, because it works on rh 7.1
Last thing I did was to use the ifcfg-eth0 file form rh 7.1, and ifup eht0
also fails with the check cable message
The ifcfg-eth0 file form rh 7.1 looks like this:

DEVICE=eth0
USERCTL=yes
ONBOOT=no
BOOTPROTO=dhcp
BROADCAST=
NETWORK=
NETMASK=
IPADDR=

The line "alias eth0 8139too" is present in /etc/modules.conf and the
module 8139too loads without problem (both things in roswell)

How reproducible:
Always

Steps to Reproduce:
1.Try to configure the card and connection
2.ifup eth0
3.no connection
4.Try to manually edit the config files
5.ifup eth0
6.No connection
7.Use working config file (ifcfg-eth0) form redhat 7.1
8.Again no connection

Additional info:
Comment 1 Trond Eivind Glomsrxd 2001-08-08 21:17:06 EDT
Can you try the version of redhat-config-network currently available at 
ftp://people.redhat.com/pknirsch/ and see if the problem still exists?
Comment 2 nboric 2001-08-08 21:42:08 EDT
I just installed it, deleted the old config, created a new one, and the
ifcfg-eth0 file generated looks like this:

BOOTPROTO=dhcp
DEVICE=eth0:0
TYPE=Ethernet
ONBOOT=no
USERCTL=yes
PEERDNS=no

When I do ifup eth0 I get:

Determning IP information for eth0:0... failed; no link present. Check cable?
Comment 3 Trond Eivind Glomsrxd 2001-08-08 21:44:58 EDT
Get the initscripts as well.
Comment 4 nboric 2001-08-08 22:09:12 EDT
I updated initscripts from rawhide, and now I get:
Determning IP information for eth0:0... failed

Comment 5 Trond Eivind Glomsrxd 2001-08-08 22:36:56 EDT
Was this an upgrade or fresh install? Is /sbin/dhcpcd
 installed?
Comment 6 nboric 2001-08-08 22:53:06 EDT
Fresh install
Yes, /sbin/dhcpcd is installed
Comment 7 Harald Hoyer 2001-08-09 04:20:16 EDT
Then try to turn off 'Device Alias' (:0) support. I think device eth0 is not 
up.
Comment 8 David Sainty 2001-08-09 12:51:19 EDT
I have an 8139too myself, and mii-tool, which was called by ifup in roswell,
gave false diag info for the card:

e.g.:  /sbin/mii-tool eth1
eth1: 10 Mbit, half duplex, no link

This was regardless of the fact that there WAS a link (green light on, on the
card), and whether or not I forced 100 Mbit etc on inserting the module (module
options) or via the mii-tool itself.

See # 51278.  initscripts fix this, in rawhide.   I wonder if the initscripts
nboric has, actually have the change so mii-tool is not used any more.  What
initscripts do you currently have (rpm -q initscripts)?

- initscripts-6.10-1 doesn't work.
- initscripts-6.12-1 does work.

Comment 9 nboric 2001-08-09 16:58:02 EDT
I have initscripts-6.11-1, wich I got from rawhide. I can't see
initscripts-6.12-1 in rawhide, initscripts-6.11-1 is the current version, and it
doesn't fix the problem

Comment 10 nboric 2001-08-09 17:08:30 EDT
Turning off 'Device Alias' did it. Now I can connect!!
What is this feature for?
I thought it was for adding "alias eth0 8139too" to modules.conf

Comment 11 Trond Eivind Glomsrxd 2001-08-09 22:30:51 EDT
No, it's for aliases on the same device (for multi-IP web hosting, eg.) and it
needs a newer initscripts.

Note You need to log in before you can comment on or make changes to this bug.