Bug 512925 - kpackagekit fails to install rpms without signature
kpackagekit fails to install rpms without signature
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: PolicyKit-kde (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-21 07:36 EDT by Aioanei Rares
Modified: 2009-08-26 15:00 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-26 15:00:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot of the end result. (228.56 KB, image/png)
2009-07-21 07:37 EDT, Aioanei Rares
no flags Details

  None (edit)
Description Aioanei Rares 2009-07-21 07:36:38 EDT
Description of problem:

kpackagekit fails to install rpm's without signature

Version-Release number of selected component (if applicable):

0.4.1.1

How reproducible:

Every time


Steps to Reproduce:
1.For example, go to http://get.adobe.com/flashplayer/thankyou/?installer=Flash_Player_10_for_Linux_%28YUM%29 and try to install the yum repo 
as a rpm; you'll be given the chance to save/install with kpackagekit; select install
2.Confirm that it's ok to install unsigned packages
3.
  
Actual results:

See screenshot.

Expected results:


Additional info:
Comment 1 Aioanei Rares 2009-07-21 07:37:52 EDT
Created attachment 354465 [details]
Screenshot of the end result.
Comment 2 Steven M. Parrish 2009-07-21 07:49:20 EDT
I've had no problems installing unsigned RPMs recently.  Maybe it has something to do just with the Adobe RPM.   Will do some investigating.

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Kevin Kofler 2009-07-21 08:18:55 EDT
It's Rawhide, so this looks like fallout from PolicyKit 1.
Comment 4 Richard Hughes 2009-08-10 07:00:09 EDT
Well, there's no KDE version of an authentication agent for polkit1...
Comment 5 Richard Hughes 2009-08-10 07:04:29 EDT
Grrr, changing component correctly as Midori doesn't seem to handle bugzilla well...
Comment 6 Steven M. Parrish 2009-08-26 15:00:46 EDT
This is fixed in the current release of Packagekit and Kpackagekit.  Please upgrade to the newest versions.  Feel free to reopen this bug if the problem persists.

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.