Bug 512953 - (CVE-2009-2559) CVE-2009-2559 Wireshark-1.2.0: DoS (crash) due array index error in IPMI dissector
CVE-2009-2559 Wireshark-1.2.0: DoS (crash) due array index error in IPMI diss...
Status: CLOSED ERRATA
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
https://bugs.wireshark.org/bugzilla/s...
impact=moderate,public=20090720,repor...
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-21 09:29 EDT by Jan Lieskovsky
Modified: 2010-06-25 05:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-25 05:48:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Lieskovsky 2009-07-21 09:29:42 EDT
An array index error was found in the Wireshark's IPMI dissector. 
A remote attacker could create a specially-crafted IPMI packet
capture file, which once opened by an unsuspecting user would
lead to denial of service (Wireshark crash). 

References:
----------
http://www.wireshark.org/security/wnpa-sec-2009-04.html
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=3559

Reproducer:
-----------
https://bugs.wireshark.org/bugzilla/attachment.cgi?id=3157

Upstream patch:
--------------
http://anonsvn.wireshark.org/viewvc/trunk/epan/dissectors/packet-ipmi-se.c?r1=28801&r2=28800&pathrev=28801&view=patch
Comment 1 Jan Lieskovsky 2009-07-21 09:33:16 EDT
This issue does NOT affect the versions of the wireshark package, as shipped
with Red Hat Enterprise Linux 3, 4, and 5.

This issue does NOT affect the version of the wireshark package, as shipped
with Fedora release of 10.

This issue affects the versions (wireshark-1.2.0-1.fc{11,12}) of the
wireshark package, as shipped with Fedora releases of 11 and Rawhide.
Comment 2 Jan Lieskovsky 2009-07-21 15:45:50 EDT
MITRE's CVE-2009-2559 entry:

Buffer overflow in the IPMI dissector in Wireshark 1.2.0 allows remote
attackers to cause a denial of service (crash) via unspecified vectors
related to an array index error. NOTE: some of these details are
obtained from third party information.

References:
----------
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-2559
http://www.wireshark.org/security/wnpa-sec-2009-04.html
http://www.securityfocus.com/bid/35748
http://secunia.com/advisories/35884
http://www.vupen.com/english/advisories/2009/1970
Comment 3 Jan Lieskovsky 2009-08-12 06:31:32 EDT
Official statement from Red Hat Security Response Team regarding this issue:
----------------------------------------------------------------------------

Not vulnerable. This issue did not affect the versions of the Wireshark
package, as shipped with Red Hat Enterprise Linux 3, 4, or 5.
Comment 4 Fedora Update System 2009-11-04 07:02:06 EST
wireshark-1.2.2-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2009-12-04 18:38:40 EST
wireshark-1.2.1-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.