Bug 513044 - stellarium crashes kernel at startup
stellarium crashes kernel at startup
Status: CLOSED DUPLICATE of bug 509519
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-21 14:38 EDT by Alex Lancaster
Modified: 2009-11-15 16:21 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-02 12:35:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2009-07-21 14:38:56 EDT
This is with an Intel Integrated Graphics card X4500.  The driver is listed in hwbrowser as i915.

Possibly a problem with the way stellarium interacts with intel driver and DRI.

Jul 21 10:27:09 localhost kernel: ------------[ cut here ]------------
Jul 21 10:27:09 localhost kernel: kernel BUG at drivers/gpu/drm/i915/i915_gem.c:2136!
Jul 21 10:27:09 localhost kernel: invalid opcode: 0000 [#1] SMP 
Jul 21 10:27:09 localhost kernel: last sysfs file: /sys/devices/pci0000:00/0000:00:1f.2/host0/target0:0:0/0:0:0:0/block/sda/sda3/stat
Jul 21 10:27:09 localhost kernel: CPU 1 
Jul 21 10:27:09 localhost kernel: Modules linked in: fuse bridge stp llc bnep sco l2cap bluetooth sunrpc ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 cpufreq_ondemand acpi_cpufreq freq_table dm_multipath uinput snd_hda_codec_intelhdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_usb_audio snd_usb_lib snd_rawmidi snd_pcm snd_seq_device snd_timer snd_hwdep snd quickcam_messenger usbvideo firewire_ohci pcspkr usb_storage firewire_core iTCO_wdt videodev wmi e1000e v4l1_compat soundcore i2c_i801 v4l2_compat_ioctl32 snd_page_alloc crc_itu_t serio_raw iTCO_vendor_support joydev i915 drm i2c_algo_bit i2c_core video output [last unloaded: microcode]
Jul 21 10:27:09 localhost kernel: Pid: 2958, comm: stellarium Not tainted 2.6.29.5-191.fc11.x86_64 #1 SX2800-01
Jul 21 10:27:09 localhost kernel: RIP: 0010:[<ffffffffa005f3d2>]  [<ffffffffa005f3d2>] i915_gem_object_get_fence_reg+0x221/0x61e [i915]
Jul 21 10:27:09 localhost kernel: RSP: 0000:ffff8801268cdbe8  EFLAGS: 00010202
Jul 21 10:27:09 localhost kernel: RAX: 000000000000966b RBX: ffff88010f9d6d80 RCX: 0000000000000010
Jul 21 10:27:09 localhost kernel: RDX: 0000000000002e22 RSI: 000000000000966b RDI: ffff88010f9d66c0
Jul 21 10:27:09 localhost kernel: RBP: ffff8801268cdc28 R08: 0000000000000003 R09: ffff88013d1271e8
Jul 21 10:27:09 localhost kernel: R10: 6db6db6db6db6db7 R11: 00001e0000000000 R12: ffff88010f9d6840
Jul 21 10:27:09 localhost kernel: R13: ffff88013d127000 R14: ffff88010f9d6f00 R15: ffff88013d126000
Jul 21 10:27:09 localhost kernel: FS:  00007f4899a9c820(0000) GS:ffff88013ea7a280(0000) knlGS:0000000000000000
Jul 21 10:27:09 localhost kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Jul 21 10:27:09 localhost kernel: CR2: 00007f48888d5000 CR3: 000000010f820000 CR4: 00000000000406e0
Jul 21 10:27:09 localhost kernel: DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
Jul 21 10:27:09 localhost kernel: DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Jul 21 10:27:09 localhost kernel: Process stellarium (pid: 2958, threadinfo ffff8801268cc000, task ffff880129925c00)
Jul 21 10:27:09 localhost kernel: Stack:
Jul 21 10:27:09 localhost kernel: ffff8801268cdc28 ffff88013d1271e8 ffff88013d126020 ffff88010f9d6f00
Jul 21 10:27:09 localhost kernel: ffff88013d126020 ffff88010f9d6d80 ffff8801299dc8f0 ffff8801268cdce8
Jul 21 10:27:09 localhost kernel: ffff8801268cdc98 ffffffffa00610d3 ffff8801268cdc48 00007f48888d5000
Jul 21 10:27:09 localhost kernel: Call Trace:
Jul 21 10:27:09 localhost kernel: [<ffffffffa00610d3>] i915_gem_fault+0xc1/0x136 [i915]
Jul 21 10:27:09 localhost kernel: [<ffffffff810b213f>] __do_fault+0x55/0x3d5
Jul 21 10:27:09 localhost kernel: [<ffffffffa002bb3b>] ? drm_mm_put_block+0xa2/0xba [drm]



Full kernel oops report here

http://www.kerneloops.org/submitresult.php?number=559649
Comment 1 Alex Lancaster 2009-07-21 14:39:56 EDT
Version is:

stellarium-0.10.2-2.fc11.x86_64
Comment 2 Jochen Schmitt 2009-07-21 15:20:33 EDT
On my nvidia graphic adapter stellarium works fine. Stallarium use the OpenGL capabilities for Qt4.


From my point of view this is a graphic driver issue.
Comment 3 David L. 2009-07-24 11:41:56 EDT
There seem to be a number of bugs that show the 

kernel BUG at drivers/gpu/drm/i915/i915_gem.c:2136!

line. Such as https://bugzilla.redhat.com/show_bug.cgi?id=509519

This bug suggests downgrading the mesa packages from 7.6 to 7.5 version. I did this (using rpm rather than yum) and stellarium now is usable. Note by opening a number of dialog windows I have still been able to get stellarium to freeze with the same symptoms as above -- so I believe the problem is still with the intel driver -- but at least postponed with this workaround.
Comment 4 Thomas Janssen 2009-08-02 12:35:13 EDT

*** This bug has been marked as a duplicate of bug 509519 ***

Note You need to log in before you can comment on or make changes to this bug.