Bug 51307 - SSH2 authentication problems + openssh-askpass-gnome problems
SSH2 authentication problems + openssh-askpass-gnome problems
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-09 07:47 EDT by Need Real Name
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-03 07:04:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-08-09 07:47:40 EDT
Hi!

I am running a RH7.1 machine with OpenSSH 2.9p2-3 installed (from Rawhide)
[ted@lorient ~]$ rpm -qa | grep ssh
openssh-askpass-gnome-2.9p2-3
openssh-askpass-2.9p2-3
openssh-clients-2.9p2-3
openssh-2.9p2-3
openssh-server-2.9p2-3

I am following the procedures given in, I use Gnome and KDM:

http://www.europe.redhat.com/documentation/rhl7.1/rhl-cg-en-7.1/openssh-clients.php3

and I am using the rsa SSH2 protocol (ssh-keygen -t rsa)

[ted@lorient ~/.ssh]$ ls -la
total 24
drwx------    2 ted      users        4096 Aug  9 10:38 .
drwx------   40 ted      users        4096 Aug  9 12:26 ..
-rw-r--r--    1 ted      users         226 Aug  9 10:38 authorized_keys2
-rw-------    1 ted      users         951 Aug  9 10:34 id_rsa
-rw-r--r--    1 ted      users         228 Aug  9 10:34 id_rsa.pub




I have two problems:
In init 3, openssh-askpass-gnome shows up and works
In init 5, it does not

I use kdm (so I am running the machine in init 5) so, I don't get the
openssh-askpass-gnome...


Second problem: The authentication does not work. When I type ssh
remote-machine, ssh generates a known_hosts2 file and does not care about
the authorized files


Any explanation?


		Daniel
Comment 1 Brian Brock 2001-08-15 13:46:58 EDT
Can you give a little more detail in what you mean by "doesn't care about the
authorized files" in your second problem?  I don't know which symptoms you're
seeing / referring to, and how they differ from your expectations.
Comment 2 Need Real Name 2001-08-27 04:26:12 EDT
Hello,

You are right, my description of the second problem is not very clear...
Sorry...
Well, I simply meant that the presence of the authorized_keys2 files did not
change a thing. Ssh is always willing to generate or update known_hosts2 files.
This is quiet boring because I have to type the password all the time instead of
using the paraphrase once and for all during the login process.
Comment 3 Nalin Dahyabhai 2002-03-07 14:25:56 EST
Just to be certain, the authorized_keys2 file is on the server you're attempting
to log into, right?  Storing it on the machine you're connecting from doesn't
help unless your home directory is shared over the network between the two.
Comment 4 Need Real Name 2002-03-08 07:44:26 EST
Well, I had misunderstood the use of known_hosts
RedHat 7.2 seems to have also the problem with openssh-askpass-gnome solved (Now
I have a little window at Log in under Gnome) so things are under control...

Thanks anyway for your answer

BTW, Isn't it possible to get a "openssh-askpass-KDE" as well?

Daniel

Note You need to log in before you can comment on or make changes to this bug.