Bug 513096 - php-pecl-runkit does not work with current php (fix included)
Summary: php-pecl-runkit does not work with current php (fix included)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: php-pecl-runkit
Version: 11
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Pavel Alexeev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-07-21 23:24 UTC by Stefan Neufeind
Modified: 2009-12-20 20:09 UTC (History)
2 users (show)

Fixed In Version: 0.9-12.CVS20090215.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-07-31 08:11:00 UTC


Attachments (Terms of Use)

Description Stefan Neufeind 2009-07-21 23:24:14 UTC
The binary package php-pecl-runkit-0.9-10.CVS20090215.fc11.x86_64 installs fine for me. And I can also rebuild it fine from the SRPM. But using the current package with the php-version included in F11 results in an error on php-startup.

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/runkit.so' - /usr/lib64/php/modules/runkit.so: undefined symbol: Z_ADDREF_P in Unknown on line 0

This is due to a patch for an open/resolved but as can be found at:
http://pecl.php.net/bugs/bug.php?id=13363
However afaik this is needed only for newer php-versions than shipped with F11.

Removing
Patch1:                php-pecl-runkit-0.9-ZVAL_ADDREF.patch
from the spec (not applying that specific patch) still makes it build find, but this time also php managed to startup fine :-)

(I guess the fix might be needed with newer PHP-versions again, but not with the current one. Even "development" doesn't yet seem to ship php 5.3.)

Comment 1 Pavel Alexeev 2009-07-22 08:43:12 UTC
Thank you for the report.

Yes, this my patch intended primary for PHP-5.3.0 which shortly come to rawhide.

So, I try add some magic and version dependent patch applying.

Comment 2 Pavel Alexeev 2009-07-30 18:04:21 UTC
Please, try this build: http://koji.fedoraproject.org/koji/taskinfo?taskID=1566661
I believe this should resolve trouble.

Comment 3 Stefan Neufeind 2009-07-30 18:15:09 UTC
That build has dep-problems against the current F11-build of php:

error: Failed dependencies:
        php(api) = 20090626 is needed by php-pecl-runkit-0.9-12.CVS20090215.fc12.x86_64
        php(zend-abi) = 20090626 is needed by php-pecl-runkit-0.9-12.CVS20090215.fc12.x86_64

Was it maybe build against rawhide or so? That what the
Buildroot  	 /var/lib/mock/dist-f12-build-549132-80477
also seems to suggest. But it's a bit weird:
Parent  	 build (dist-f12, php-pecl-runkit-0.9-12.CVS20090215.fc11.src.rpm)

So against what was it built? :-)

Comment 4 Pavel Alexeev 2009-07-30 20:15:49 UTC
Yes, it is rawhide.
Fedora 11 build if you want: http://koji.fedoraproject.org/koji/taskinfo?taskID=1567443

Comment 5 Stefan Neufeind 2009-07-30 21:23:05 UTC
I can confirm that build works fine on F11 with current php. Did a basic function-test of the extension as well. This resolves the issue introduced because of the patches which were in place for php 5.3.

Comment 6 Fedora Update System 2009-07-31 08:08:15 UTC
php-pecl-runkit-0.9-12.CVS20090215.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/php-pecl-runkit-0.9-12.CVS20090215.fc10

Comment 7 Fedora Update System 2009-07-31 08:08:46 UTC
php-pecl-runkit-0.9-12.CVS20090215.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/php-pecl-runkit-0.9-12.CVS20090215.fc11

Comment 8 Fedora Update System 2009-07-31 08:09:15 UTC
php-pecl-runkit-0.9-12.CVS20090215.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/php-pecl-runkit-0.9-12.CVS20090215.el5

Comment 9 Fedora Update System 2009-08-18 00:21:44 UTC
php-pecl-runkit-0.9-12.CVS20090215.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2009-08-18 21:12:35 UTC
php-pecl-runkit-0.9-12.CVS20090215.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2009-08-18 21:13:04 UTC
php-pecl-runkit-0.9-12.CVS20090215.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Bas Mevissen 2009-12-03 12:33:06 UTC
Package php-pecl-runkit-0.9-12.CVS20090215.el5 still has this problem:

$ php
(nothing)

sudo yum install php-pecl-runkit
(...)

$ php
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/runkit.so' - /usr/lib64/php/modules/runkit.so: undefined symbol: Z_ADDREF_P in Unknown on line 0

Removing the php-pecl-runkit package resolves the issue.

System is CentOS 5.4, up to date with all PHP stuff installed from Fedora EPEL 5.

Comment 13 Pavel Alexeev 2009-12-06 02:16:15 UTC
Version of php?

Comment 14 Bas Mevissen 2009-12-06 20:48:20 UTC
php version 5.1.6-23.2.el5_3 on a x86_64 system.

Comment 15 Pavel Alexeev 2009-12-13 13:29:58 UTC
Hm, you are sure what use php-pecl-runkit-0.9-12.CVS20090215.el5 version? Strange, it still only in epel-testing. And if I install it from testing I can't reproduce error:

$ php -v
PHP 5.1.6 (cli) (built: Apr  7 2009 08:00:04) 
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies

Comment 16 Bas Mevissen 2009-12-14 10:34:17 UTC
You are right. I'm running php-pecl-runkit-0.9-11.CVS20090215.el5.x86_64.rpm. I overlooked the -11 and -12 difference in the version when looking at the fc10/fc11 versions.

So php-pecl-runkit-0.9-11.CVS20090215.el5.x86_64.rpm has the problem I reported in #12 and php-pecl-runkit-0.9-12.CVS20090215.el5.x86_64.rpm from epel-testing seems fine when I install it from epel-testing.

In summary, the package from epel-testing needs to be pushed to epel?

Comment 17 Pavel Alexeev 2009-12-20 16:12:30 UTC
According to comment#9 it is pushed to stable... I don't known why it is not happened until now. If you want, I can fill ticket to fesco infrastructure with this question.

Comment 18 Bas Mevissen 2009-12-20 18:35:32 UTC
Yes, please. Saves other people time to figure this out.

Comment 19 Pavel Alexeev 2009-12-20 20:09:18 UTC
https://fedorahosted.org/rel-eng/ticket/3215


Note You need to log in before you can comment on or make changes to this bug.