Bug 513103 - Bluetooth not working on Dell Studion XPS 16
Bluetooth not working on Dell Studion XPS 16
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-21 19:41 EDT by Rodd Clarkson
Modified: 2009-11-05 19:07 EST (History)
4 users (show)

See Also:
Fixed In Version: 4.42-9.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-05 19:07:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rodd Clarkson 2009-07-21 19:41:27 EDT
Description of problem:

I've recently purchased a Dell Studion XPS 16 (see lspci -nn below) with a bluetooth device in it.

When I start the laptop, the bluetooth light is one, however, bluetooth doesn't seem to work.

Foe example, if I go to System > Preferences > Bluetooth the dialog reports that "Your computer does not have any Bluetooth adapters plugged in."

I found comments on google about running hid2hci which I tried.

$ hid2hci 
Switching device 413c:8158 to HCI mode failed (Operation not permitted)
$ sudo hid2hci 
Switching device 413c:8158 to HCI mode was successful

After running this System > Preferences > Bluetooth seems to be working.

I can discover Bluetooth devices (my palm zire72 for example)

I haven't managed to get my Palm to sync yet, but currently I'd just like it to appear and bluetooth to work without having to type hid2hci.


Version-Release number of selected component (if applicable):

$ rpm -qa bluez\*
bluez-cups-4.37-2.fc11.x86_64
bluez-4.37-2.fc11.x86_64
bluez-libs-4.37-2.fc11.x86_64



How reproducible:

After each reboot.



Steps to Reproduce:
1. Restart laptop
2. Select System > Preferences > Bluetooth

  
Actual results:

System reports no bluetooth device


Expected results:

Blue tooth should be there.


Additional info:

$ lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub [8086:2a40] (rev 07)
00:01.0 PCI bridge [0604]: Intel Corporation Mobile 4 Series Chipset PCI Express Graphics Port [8086:2a41] (rev 07)
00:1a.0 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 [8086:2937] (rev 03)
00:1a.1 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 [8086:2938] (rev 03)
00:1a.2 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 [8086:2939] (rev 03)
00:1a.7 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 [8086:293c] (rev 03)
00:1b.0 Audio device [0403]: Intel Corporation 82801I (ICH9 Family) HD Audio Controller [8086:293e] (rev 03)
00:1c.0 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 [8086:2940] (rev 03)
00:1c.1 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 [8086:2942] (rev 03)
00:1c.3 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 [8086:2946] (rev 03)
00:1c.5 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 [8086:294a] (rev 03)
00:1d.0 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 [8086:2934] (rev 03)
00:1d.1 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 [8086:2935] (rev 03)
00:1d.2 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 [8086:2936] (rev 03)
00:1d.7 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 [8086:293a] (rev 03)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev 93)
00:1f.0 ISA bridge [0601]: Intel Corporation ICH9M LPC Interface Controller [8086:2919] (rev 03)
00:1f.2 SATA controller [0106]: Intel Corporation ICH9M/M-E SATA AHCI Controller [8086:2929] (rev 03)
00:1f.3 SMBus [0c05]: Intel Corporation 82801I (ICH9 Family) SMBus Controller [8086:2930] (rev 03)
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Radeon Mobility HD 3670 [1002:9593]
01:00.1 Audio device [0403]: ATI Technologies Inc RV635 Audio device [Radeon HD 3600 Series] [1002:aa20]
04:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 5300 AGN [Shiloh] Network Connection [8086:4235]
08:00.0 Ethernet controller [0200]: Broadcom Corporation NetLink BCM5784M Gigabit Ethernet PCIe [14e4:1698] (rev 10)
09:01.0 FireWire (IEEE 1394) [0c00]: Ricoh Co Ltd R5C832 IEEE 1394 Controller [1180:0832] (rev 05)
09:01.1 SD Host controller [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter [1180:0822] (rev 22)
09:01.2 System peripheral [0880]: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter [1180:0592] (rev 12)
09:01.3 System peripheral [0880]: Ricoh Co Ltd xD-Picture Card Controller [1180:0852] (rev 12)
Comment 1 Bastien Nocera 2009-07-21 21:10:08 EDT
The behaviour is completely correct. You'll need to enable hid2hci in /etc/sysconfig/bluetooth and it will be run on each boot (make sure the bluetooth service is enabled, which it is by default).
Comment 2 Rodd Clarkson 2009-07-22 04:40:58 EDT
I don't get it.  Doesn't this leave bluetooth less than useful unless someone knows to hack a file by hand.

At the very least there should be some sort of comment about this somewhere, or better a switch to enable this in the application.
Comment 3 Rodd Clarkson 2009-07-22 08:17:38 EDT
Also, I enabled the two options in /etc/sysconfig/bluetooth and suspend resume stopped working.

Commenting out the two lines and then rebooting fixes things and suspend and resume works again.
Comment 4 Bastien Nocera 2009-07-22 13:03:41 EDT
(In reply to comment #2)
> I don't get it.  Doesn't this leave bluetooth less than useful unless someone
> knows to hack a file by hand.

Welcome to Linux.

> At the very least there should be some sort of comment about this somewhere, or
> better a switch to enable this in the application.  

I won't add any sort of hacks for those devices. The situation in this particular case hasn't changed since the very first release of bluez (or bluez-utils) containing hid2hci.

If we had documentation for those devices and were able to read link keys off of them, then we'd enable the Bluetooth support all the time (the same way MacOS X does on Apple machines). But we don't.

As for your suspend problems, file bugs against the kernel, they're unlikely to be related to hid2hci.
Comment 5 Rodd Clarkson 2009-07-22 19:48:41 EDT
(In reply to comment #4)
> (In reply to comment #2)
> > I don't get it.  Doesn't this leave bluetooth less than useful unless someone
> > knows to hack a file by hand.
> 
> Welcome to Linux.

It's a bit late for welcomes ;-]  I've been using Linux since 1997 so I'm quite used to hacking on text files.  But I thought the whole point of Linux moving forward is that I shouldn't have too.  Things should just work, and that config options like this should be accessible without using sudo vi.

> > At the very least there should be some sort of comment about this somewhere, or
> > better a switch to enable this in the application.  
> 
> I won't add any sort of hacks for those devices. The situation in this
> particular case hasn't changed since the very first release of bluez (or
> bluez-utils) containing hid2hci.
> 
> If we had documentation for those devices and were able to read link keys off
> of them, then we'd enable the Bluetooth support all the time (the same way
> MacOS X does on Apple machines). But we don't.

But my bluetooth device works fine (as far as I can tell, and with the exception of suspend issues) once hid2hci is enabled.  I'm able to sync with my Palm for example.

> As for your suspend problems, file bugs against the kernel, they're unlikely to
> be related to hid2hci.  

I've filed a bug against the kernel, but if I run hid2hdi then suspend resume fails, and if I don't then it works.  Of course, if don't then bluetooth doesn't work.  Arggghhhh!
Comment 6 David Woodhouse 2009-07-22 20:31:28 EDT
One hack to work around the suspend problem is running 'hid2hci --tohid' before suspend, and running hid2hci again on resume (although the latter may well be happening anyway since the device has been reset).
Comment 7 Bastien Nocera 2009-07-23 04:48:46 EDT
<snip>
> But my bluetooth device works fine (as far as I can tell, and with the
> exception of suspend issues) once hid2hci is enabled.  I'm able to sync with my
> Palm for example.

Except that we can't detect whether the device is within a laptop, or a desktop, and on a desktop you'd just have lost your mouse and keyboard.
Comment 8 David Woodhouse 2009-07-23 06:26:42 EDT
You do know if you have a keyboard/mouse other than the ones on the HID device in question. And we _could_ give the user some easier way to choose, other than having to edit files manually.
Comment 9 Bastien Nocera 2009-07-23 06:37:25 EDT
(In reply to comment #8)
> You do know if you have a keyboard/mouse other than the ones on the HID device
> in question. And we _could_ give the user some easier way to choose, other than
> having to edit files manually.  

We could enable the switching regardless when we have a pairing assistant (as available in MacOS X). See:
http://bugzilla.gnome.org/show_bug.cgi?id=556301

That's currently waiting on XInput2 support in GTK+ to do the enumeration/hotplug.
Comment 11 Rodd Clarkson 2009-08-19 22:10:37 EDT
Okay, after quite a few bluez updates that seem to completely break bluetooth, I noticed that after the current update, when I start my laptop, the bluetooth icon is in the notification area without any intervention by myself.  This is great.

Even better, I can sync my Palm Zire72 using Bluetooth.  Fantastic.

However, after a suspend/resume cycle, the icon disappears and if I run S > P > Bluetooth, it says no bluetooth device exists.
Comment 12 Rodd Clarkson 2009-08-19 22:12:09 EDT
Oh, and I reopened the bug because while it was closed early on in the piece, later input would suggest that something is actually being done to address the issues reported and as such it feels like the bug is actually open and being address (which is great).
Comment 14 Rodd Clarkson 2009-09-18 07:01:44 EDT
I've installed the koji stuff above.

I'm not sure if I was meant to do something with the 'Might also be necessary' stuff and haven't.

After a reboot (not necessary, but nice to know it's all going to work like it should) I no longer see a bluetooth icon in the notification area and trying to run the bluetooth tool in System > Preferences says I don't have any bluetooth devices.

This is a regression from the previous version I had installed.
Comment 15 Rodd Clarkson 2009-10-14 19:53:03 EDT
It's now a month since this bug was updated and bluetooth is still 'no working' for me (with all recent updates installed).
Comment 16 Bastien Nocera 2009-11-02 14:48:44 EST
Please test with:
http://koji.fedoraproject.org/koji/buildinfo?buildID=139403
Comment 17 Rodd Clarkson 2009-11-02 16:51:36 EST
Bastien,

I've tried the packages above and they work great.

I had been using bluez-4.56-1 which worked on boot, but when you cycled through a suspend and resume, the icon disappeared and then /system/preferences/bluetooth would say no bluetooth device existed.

However, I can cycle through suspend/resume cycles and the icon reappears and appears to work fine.

Does this give you something to work with.

Hmmm, work noting that this is on an f12 box.  I didn't notice that the packages you offer where f11.

So, is it possible to test this fix in f12 with f12 packages too.

I'll try and test them in f11 for you.
Comment 18 Bastien Nocera 2009-11-02 18:59:09 EST
Which one do you use?

If you use F12, file a bug against udev which is where the hid2hci mechanics live. If you use F11, then you'll want this package.

Does it work with the above package on F11?
Comment 19 Rodd Clarkson 2009-11-03 01:49:21 EST
Strangely, it doesn't work in f11, but it does work in f12.

It's an improvement in f11.  At least bluetooth is now appearing when I log in the first time, but after cycling through suspend and resume, it doesn't appear again.

I'm happy to file a bug against udev for f12, but would like to know what I need to tell them to do.
Comment 20 Fedora Update System 2009-11-03 05:03:44 EST
bluez-4.42-9.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/bluez-4.42-9.fc11
Comment 21 Fedora Update System 2009-11-04 07:12:55 EST
bluez-4.42-9.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bluez'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10931
Comment 22 Rodd Clarkson 2009-11-04 18:43:45 EST
Bastien,

What do I need to ask the udev guys to do to get bluez working in f12?

I've file a bug, but I don't know what to ask them to do.

https://bugzilla.redhat.com/show_bug.cgi?id=532628
Comment 23 Fedora Update System 2009-11-05 19:07:10 EST
bluez-4.42-9.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.