Bug 513142 - tries to load libibus.so from ibus-devel
tries to load libibus.so from ibus-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Alpha/F12AlphaBlocker
  Show dependency treegraph
 
Reported: 2009-07-22 04:27 EDT by Jens Petersen
Modified: 2009-07-22 07:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 07:00:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2009-07-22 04:27:12 EDT
Description of problem:
There seems to be a runtime problem with current rawhide ibus.
It is trying to dl libibus.so which is from ibus-devel.

Version-Release number of selected component (if applicable):
ibus-1.2.0.20090719-1.fc12

How reproducible:
every time

Steps to Reproduce:
0. rpm -q ibus-devel
1. run ibus-setup
  
Actual results:
0. package ibus-devel is not installed
1.
Traceback (most recent call last):
  File "/usr/share/ibus/setup/main.py", line 31, in <module>
    import ibus
  File "/usr/lib/python2.6/site-packages/ibus/__init__.py", line 25, in <module>
    from common import *
  File "/usr/lib/python2.6/site-packages/ibus/common.py", line 97, in <module>
    libibus = ctypes.CDLL("libibus.so")
  File "/usr/lib/python2.6/ctypes/__init__.py", line 353, in __init__
    self._handle = _dlopen(self._name, mode)
OSError: libibus.so: cannot open shared object file: No such file or directory

Expected results:
1. no backtrace

Additional info:
ibus panel does not start either.

Workaround is to install ibus-devel, but runtime should not require
ibus-devel.
Comment 1 Peng Huang 2009-07-22 07:00:54 EDT
Fixed in 1.2.0.20090722.

Note You need to log in before you can comment on or make changes to this bug.