Bug 513283 - Should be obvious prior to device purchase that proprietary software is required
Summary: Should be obvious prior to device purchase that proprietary software is required
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-07-22 20:21 UTC by markm
Modified: 2009-11-13 02:32 UTC (History)
2 users (show)

Fixed In Version: 3.9.8-18.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-13 02:32:09 UTC


Attachments (Terms of Use)
output from lpinfo (2.24 KB, text/plain)
2009-07-23 20:40 UTC, markm
no flags Details
Enabling debug mode freezes indefinitely (252.46 KB, image/png)
2009-07-23 20:41 UTC, markm
no flags Details
Debug output from Troubleshoot option (62.20 KB, text/plain)
2009-07-23 21:42 UTC, markm
no flags Details


Links
System ID Priority Status Summary Last Updated
Launchpad 471223 None None None Never

Description markm 2009-07-22 20:21:21 UTC
Description of problem:

Just bought brand new HP LaserJet P1006 desktop printer, printer correctly installed and connected to the computer is also detected correctly by cups, but nothing gets printed. All jobs remains in the queue with status “processing”.

Version-Release number of selected component (if applicable):

bluez-cups-4.37-2.fc11.i586
cups-libs-1.4-0.b2.18.fc11.i586
cups-pdf-2.5.0-2.fc11.i586
cups-devel-1.4-0.b2.18.fc11.i586
gutenprint-cups-5.2.3-5.fc11.i586
cups-1.4-0.b2.18.fc11.i586
libgnomecups-0.2.3-6.fc11.i586
cups-pk-helper-0.0.4-1.fc11.i586
hplip-libs-3.9.2-4.fc11.i586
hplip-3.9.2-4.fc11.i586

How reproducible:

tested on two different laptops, both equipped with Fedora 11.

Steps to Reproduce:
1. Attach printer using USB cable, switch it on
2. Run system-config-printer
3. In your printer's setting try to print a test page
  
Actual results:

Job is added to the queue and remains there with status “processing”, after a few minutes applet will popup a message asking whether printer is connected or not.

Expected results:

Printer should print the test page.

Additional info:

I've tried also foo2xqx driver from rpmfusion - it didn't work too.
Then tried a driver from http://foo2xqx.rkkda.com/ and it eventually worked, though I am not happy with manually installed driver.

Comment 1 Jiri Popelka 2009-07-23 11:47:09 UTC
1)
Please attach the output of this command:
lpinfo -l -v

2)
System->Administration->Printing, then Help->Troubleshoot from the menu bar.
Select your printer, enable debugging, try to print test page
and save the diagnostic output.
Attach the output here.

Comment 2 markm 2009-07-23 20:40:05 UTC
Created attachment 354923 [details]
output from lpinfo

Comment 3 markm 2009-07-23 20:41:45 UTC
Created attachment 354924 [details]
Enabling debug mode freezes indefinitely

I was unable to finish this task due to the fact I was unable to enable debug mode :(

Comment 4 markm 2009-07-23 21:42:35 UTC
Created attachment 354932 [details]
Debug output from Troubleshoot option

I've managed to get debug information, see troubleshoot.txt file attached.

Comment 5 Tim Waugh 2009-07-24 09:32:22 UTC
D [23/Jul/2009:22:38:19 +0100] [Job 3] unable to open PrintContext object err=48

I think this line means it needs a proprietary plug-in to work.

You should get better behaviour after applying the system-config-printer, cups and foomatic updates that were released in the last few days:
1. the troubleshooter won't freeze as in comment #3
2. the job will be stopped when the filter fails
3. system-config-printer will display a dialog allowing diagnosis

However, none of that will allow you to print.  The basic problem is there is no pure free software driver for it.

The 'hp-plugin' program will attempt to install the proprietary plug-in.

Comment 6 markm 2009-07-24 09:43:47 UTC
so there should be an information about it - note to the driver or anything like that. It's very frustrating, when user buys a printer advetised as “working with linux” then nothing happens when it comes to printing.

I am happy with the driver downloaded from http://foo2xqx.rkkda.com/ (which requires proprietary firmware). Still it's not an ideal solution, but it works.

Also, I've tried to install driver HP website - they supply hplip in version 3.9.6 (higher, than version in Fedora) - I've installed their driver, than their driver installed proprietary plugin... printer still didn't print anything, but HP installed annoying applet (windows style, does nothing just eats memory and cpu).

rpmfusion supplies foo2xqx driver, but I suspect, it doesn't include proprietary firmware, which needs to be somehow downloaded, so it didn't work either.

At least I know what to do and have printer working, thanks for your time!

Comment 7 Tim Waugh 2009-07-24 11:27:41 UTC
Re-opening for "should be obvious what went wrong, or should be obvious prior to purchase that proprietary software is required".

Comment 8 Tim Waugh 2009-11-02 16:18:05 UTC
The "should be obvious what went wrong" part is covered by bug #531330 and bug #531872.

For "should be obvious prior to purchase that proprietary software is required" I've filed a bug report upstream with a patch.

Comment 9 Fedora Update System 2009-11-04 12:15:47 UTC
hplip-3.9.8-18.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10759

Comment 10 Fedora Update System 2009-11-13 02:31:44 UTC
hplip-3.9.8-18.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.