Bug 513334 - pavucontrol overload cpu and crashes after few seconds
pavucontrol overload cpu and crashes after few seconds
Status: CLOSED DUPLICATE of bug 501769
Product: Fedora
Classification: Fedora
Component: pavucontrol (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-23 01:50 EDT by Bruno Medeiros
Modified: 2009-07-28 08:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-23 08:42:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg output (2.10 KB, text/plain)
2009-07-23 01:52 EDT, Bruno Medeiros
no flags Details
messages log (150.19 KB, text/plain)
2009-07-23 01:53 EDT, Bruno Medeiros
no flags Details
the log generated each time i open pavucontrol (49.59 KB, text/plain)
2009-07-23 02:12 EDT, Bruno Medeiros
no flags Details

  None (edit)
Description Bruno Medeiros 2009-07-23 01:50:26 EDT
Description of problem:

pavucontrol causes full load on processor and hangs after few seconds.

Version-Release number of selected component (if applicable):
pavucontrol.x86_64 0.9.8-1.fc11 

How reproducible:
Always.

Steps to Reproduce:
1. Open pavucontrol
2. Wait few seconds.
3.
  
Actual results:
pavucontrol causes a full cpu load during few seconds and after crashes with the following message: Connection failed: Connection terminated

Expected results:
pavucontrol remains opened and working correctly an arbitrary period of time, without cpu overloading.

Additional info:
This error starts when I upgraded from fedora 10 (was previously 9) to fedora 11. A have another issues here, my extra channels started working only after increasing alsa volume with the old volume control, as described here: http://fedoraproject.org/wiki/Common_F11_bugs#PulseAudio-based_volume_control_cannot_adjust_volume_satisfactorily

I have a lot of messages in /var/log/messages and I will fill another bug against alsa about this. (have attached messages log her too).
Comment 1 Bruno Medeiros 2009-07-23 01:52:13 EDT
Created attachment 354813 [details]
dmesg output
Comment 2 Bruno Medeiros 2009-07-23 01:53:11 EDT
Created attachment 354814 [details]
messages log
Comment 3 Bruno Medeiros 2009-07-23 02:12:17 EDT
Created attachment 354816 [details]
the log generated each time i open pavucontrol
Comment 4 Lennart Poettering 2009-07-23 08:42:39 EDT
Your sound driver seems to be broken. The intresting line is this one:

snd_pcm_delay() returned a value that is exceptionally large: 6377097072352565504 bytes (326791786697 ms).

*** This bug has been marked as a duplicate of bug 501769 ***
Comment 5 Bruno Medeiros 2009-07-28 08:34:07 EDT
If it's expected that the alsa error causes de pavucontrol full cpu load and crash, I believe that this bug is really a duplicated of https://bugzilla.redhat.com/show_bug.cgi?id=501769

Note You need to log in before you can comment on or make changes to this bug.