Bug 51335 - initscripts should depend on SysVinit
Summary: initscripts should depend on SysVinit
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-09 15:59 UTC by Filip Van Raemdonck
Modified: 2014-03-17 02:22 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-09 15:59:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Filip Van Raemdonck 2001-08-09 15:59:32 UTC
Description of Problem:

initscripts' /etc/init.d/functions uses pidof, which is in SysVinit.
However initscripts does not depend on SysVinit either directly or through
dependencies.
I need to build rpms from time to time, and do this on a Debian system
inside a chroot. When I build an rpm that needed to start a service, and
tested it inside this chroot, startup failed because it didn't have SysVinit.

How to reproduce:

Here's the list of packages I have installed to build the package:

MAKEDEV autoconf automake basesystem bash binutils bzip2 bzip2-devel
chkconfig cpp cracklib cracklib-dicts db1 db2 db3 dev diffutils e2fsprogs
ed file filesystem fileutils findutils gawk gcc gcc-c++ gdbm glib glibc
glibc-common glibc-devel gnupg grep gzip info initscripts kernel-headers
libstdc++ libstdc++-devel libtermcap libtool libtool-libs logrotate m4 make
mingetty mktemp modutils mount ncurses net-tools pam passwd patch perl popt
procps psmisc pwdb rpm rpm-build rpm-devel sed setup sh-utils shadow-utils
slang strace sysklogd tar termcap textutils util-linux vim-common
vim-minimal which words zlib zlib-devel

None of these depend on SysVinit. I installed my package, it went ok,
started the service, worked fine, stopped the service, failed because it
couldn't find pidof.

I know this isn't the most common situation, but just think of someone who
does actually use Redhat, and wishes to use a chroot for some services as a
security measurement. He will run into the same problem.

regards,

Filip
PS. How acceptive are you to new packages? I generally don't care about
things I package for Redhat systems, as they are usually to fullfill very
specific needs, but this one is rather general-purpose and I think it could
be a useful addition.

Comment 1 Bill Nottingham 2001-08-09 16:11:39 UTC
Will be fixed in 6.13-1; thanks for the feedback!


Note You need to log in before you can comment on or make changes to this bug.