Bug 513359 - Path to dhcpd.conf in /etc/cobbler/settings is wrong
Path to dhcpd.conf in /etc/cobbler/settings is wrong
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: cobbler (Show other bugs)
11
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael DeHaan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-23 05:44 EDT by cleygraf
Modified: 2009-08-10 18:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-10 18:06:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cleygraf 2009-07-23 05:44:01 EDT
Description of problem:
In /etc/cobbler/settings the line

dhcpd_conf: /etc/dhcpd.conf

is wrong, it needs to be

dhcpd_conf: /etc/dhcp/dhcpd.conf


Version-Release number of selected component (if applicable):

$ rpm -qa|grep cobbler
cobbler-1.6.6-1.fc11.x86_64
$ 

# rpm -qa|grep cobbler
cobbler-1.6.6-1.fc11.i586
# 


How reproducible:

Default install.

Steps to Reproduce:
1.
2.
3.
  
Actual results:

dhcpd does not start or does use the wrong configuration after issueing a cobbler sync 

Expected results:

dhcpd is started and uses the updated dhcpd.conf.

Additional info:
Comment 1 Michael DeHaan 2009-07-23 10:22:04 EDT
That's why it's a path in settings, so you can change it to match your install if it's different.  But yeah, there's no reason we shouldn't be laying it down right.

In the 2.0 version I think we'll probably just pay attention to the OS and write the file in the correct location based on that -- and make the setting go away.

Regardless, we do have a Trac item opened on this, so it won't be forgotten.

Leaving this open because I hate stuff closed as "WONTFIX" when it's not like it should be :)
Comment 2 Michael DeHaan 2009-08-10 18:06:03 EDT
Fixed in 2.0

Note You need to log in before you can comment on or make changes to this bug.