Bug 513361 - yum update aborts silently
Summary: yum update aborts silently
Keywords:
Status: CLOSED DUPLICATE of bug 518720
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-07-23 10:20 UTC by Ralf Corsepius
Modified: 2014-01-21 23:10 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-03 16:00:23 UTC
Type: ---


Attachments (Terms of Use)

Description Ralf Corsepius 2009-07-23 10:20:19 UTC
Description of problem:

With todays (once again broken) push of updates, 
yum aborts without any further error message midst of a yum update:

[root@mccallum] # yum update
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
updates/metalink                                                                
...
Transaction Summary
==================================================================================================================================================================================
Install      1 Package(s)         
Update      76 Package(s)         
Remove       0 Package(s)         

Total size: 185 M
Total download size: 105 M
Is this ok [y/N]: y
Downloading Packages:
http://ftp.nluug.nl/pub/os/Linux/distr/fedora/linux/updates/11/i386/java-1.6.0-openjdk-1.6.0.0-25.b16.fc11.i586.rpm: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
(1/36): java-1.6.0-openjdk-1.6.0.0-25.b16.fc11.i586.rpm                                                                                                    |  32 MB     00:25     
(2/36): kernel-2.6.29.6-213.fc11.i586.rpm                                                                                                                  |  20 MB     00:18     
http://ftp.tudelft.nl/download.fedora.redhat.com/linux/updates/11/i386/kernel-firmware-2.6.29.6-213.fc11.noarch.rpm: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
(3/36): kernel-firmware-2.6.29.6-213.fc11.noarch.rpm                                                                                                       | 501 kB     00:00     
(4/36): kernel-headers-2.6.29.6-213.fc11.i586.rpm                                                                                                          | 853 kB     00:00     
(5/36): libgweather-2.26.2.1-1.fc11.i586.rpm                                                                                                               | 5.8 MB     00:05 ... 
[root@mccallum]# 


Version-Release number of selected component (if applicable):
yum-3.2.23-3.fc11.noarch


Actual results:
The crap above. Likely yum is not able to produce something usable from the brokenness of the repos.

Expected results:
Function.

Comment 1 James Antill 2009-07-23 20:20:41 UTC
 Ralf, this is repeatable ... it always just exits? And always after downloading a couple of pkgs?
 I presume you aren't hitting C-c, right?
 This is just one box?

 Can you strace it and attach the result.

Comment 2 Ralf Corsepius 2009-07-23 20:38:15 UTC
(In reply to comment #1)
>  Ralf, this is repeatable 
Repeatable, in the sense of "happened more than once on the same machine", yes.

Repeatable, in the sense of "how to reproduce it", no.

It happened more than once within ca. 1 hour on the same machine, but wasn't repeatable on others.

> ... it always just exits?
No, this breakdown was interspersed with other breakdowns (404's, missing files).

> And always after
> downloading a couple of pkgs?
Yep.

>  I presume you aren't hitting C-c, right?
No.

>  This is just one box?
Yes.
 
>  Can you strace it and attach the result.  
I can try, but ... as I tried to indicate, earlier today, most update-repo mirrors yum redirected me to, were broken.

Seemingly, the repomd.xml didn't match the repo contents (Wild guess: mirror-manager is defective), while rpmfusion managed to screw their repos at the same time ...

So, I guess, it'll be very difficult to reproduce this issue.

Comment 3 seth vidal 2009-08-27 20:55:24 UTC
I think this is the same root cause as 518720.

http://lists.baseurl.org/pipermail/yum-devel/2009-August/005809.html

Comment 4 seth vidal 2009-09-03 16:00:23 UTC
I'm going to mark it as a duplicate unless I hear otherwise.

*** This bug has been marked as a duplicate of bug 518720 ***


Note You need to log in before you can comment on or make changes to this bug.