Bug 513417 - bnx2 initialize link status detection different from other NIC drivers
Summary: bnx2 initialize link status detection different from other NIC drivers
Keywords:
Status: CLOSED DUPLICATE of bug 517377
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.3
Hardware: All
OS: Linux
high
medium
Target Milestone: rc
: ---
Assignee: John Feeney
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks: 499522 533192
TreeView+ depends on / blocked
 
Reported: 2009-07-23 15:01 UTC by Flavio Leitner
Modified: 2009-11-16 18:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-16 18:08:47 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Flavio Leitner 2009-07-23 15:01:57 UTC
After loading bnx2 driver, ethtool shows eth1 as having a link detected.

Other drivers (i.e. e1000/e1000e) initialize the link status to 'no' by 
calling netif_carrier_off() in pci_driver->probe().

The patch is discussed upstream here:
http://patchwork.ozlabs.org/patch/29100/

On RHEL-5, bnx2, bnx2x and tg3 needs to be fixed.

Comment 1 John Feeney 2009-11-11 19:45:30 UTC
Kernel RPMs with the proposed patch to upgrade to version 2.0.2 can be found at:
http://people.redhat.com/jfeeney/.rhel5-bnx2

This kernel includes the following upstream patch:
 
  Ooiwa Naohiro - 6/24/2009
    Fix the behavior of ethtool when ONBOOT=no
    7959ea254ed18faee41160b1c50b3c9664735967
 
among others.

Any testing feedback would be appreciated.

Comment 3 John Feeney 2009-11-16 18:08:47 UTC
The specific patch that fixes this is found in the big patch that updates the bnx2 driver for RHEL5.5 so I am closing this bz as a duplicate of the big one. Thanks to all for any testing that you did for this one.

*** This bug has been marked as a duplicate of bug 517377 ***


Note You need to log in before you can comment on or make changes to this bug.