Bug 51344 - Weird bogus error message
Summary: Weird bogus error message
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhn_register   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-09 18:30 UTC by Chris Ricker
Modified: 2015-01-07 23:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-14 19:21:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Ricker 2001-08-09 18:30:49 UTC
On stock beta3, when I run rhn_register, it reports:

A protocol error occured: Internal Server Error , attempt #1
A protocol error occured: Internal Server Error , attempt #2

on STDOUT.  However, it appears to have registered correctly since I am
then allowed to up2date....

In case it helps hunt down the session which generated this, I registered a
system called station11 at ~12:30 pm MDT.  The username and email for it
were kaboom@gatech.edu

Comment 1 Adrian Likins 2001-08-09 18:55:14 UTC
I'll take a look at the server logs on beta and see what pops up. 

Typically, we retried socket and server related errors 5 times before
failing, so just having two errors would seem to indicate a transient
failure. Could of been db issues (were currently doing lots of odd
things to that db, and internal server errors are a pretty typical
results of that...)

Hopefully the db issues will quite down soon, so I can be more sure
of this kind of errors.

Comment 2 Glen Foster 2001-08-09 20:11:21 UTC
This defect is considered SHOULD-FIX for Fairfax.

Comment 3 Adrian Likins 2001-08-14 18:40:08 UTC
Have you seen this happen again since?

The code is designed to be resilent to temporary network errors,
which appears to be the case here.

Comment 4 Chris Ricker 2001-08-14 19:21:10 UTC
I haven't seen it again

Comment 5 Jay Turner 2001-08-14 21:14:10 UTC
Closing this out then.


Note You need to log in before you can comment on or make changes to this bug.