Bug 513454 - Nodoka doesn't gray out checkboxes
Summary: Nodoka doesn't gray out checkboxes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk-nodoka-engine
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Martin Sourada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-07-23 17:48 UTC by Nanley Chery
Modified: 2009-08-15 08:13 UTC (History)
1 user (show)

Fixed In Version: 0.7.2-5.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-15 08:07:48 UTC
Type: ---


Attachments (Terms of Use)
Software Update NODOKA (82.51 KB, image/png)
2009-07-23 17:48 UTC, Nanley Chery
no flags Details
Software Update MURRINE FANCY CANDY (79.53 KB, image/png)
2009-07-23 17:53 UTC, Nanley Chery
no flags Details
Patch to correctly grey out check boxes and radio buttons in TreeView (1.12 KB, patch)
2009-07-23 19:00 UTC, Martin Sourada
no flags Details | Diff
Software Update NODOKA (PATCHED) (74.25 KB, image/png)
2009-07-23 21:12 UTC, Nanley Chery
no flags Details

Description Nanley Chery 2009-07-23 17:48:15 UTC
Created attachment 354898 [details]
Software Update NODOKA

Description of problem:
The Nodoka gtk theme does not display grayed out checkboxes while installing updates in gpk-update-viewer.

Version-Release number of selected component (if applicable):
0.7.2

How reproducible:
Always

Steps to Reproduce:
1. Open gpk-update-viewer
2. Click "Install Updates"
3. 
  
Actual results:
The checkboxes in the update viewer are not grayed out.

Expected results:
The checkboxes would be grayed out to show that selections can't be changed during the installation process. 

Additional info:
During the upgrade process, switch to other themes for comparison.

Comment 1 Nanley Chery 2009-07-23 17:53:56 UTC
Created attachment 354900 [details]
Software Update MURRINE FANCY CANDY

Comment 2 Martin Sourada 2009-07-23 18:18:20 UTC
That's because we set the checkboxes state according to the state of the parent widget, which in this case is not greyed out. I don't recall though why I chose that policy...

Comment 3 Martin Sourada 2009-07-23 18:37:04 UTC
So, this behaviour was introduced here:

http://git.fedorahosted.org/git/nodoka?p=nodoka;a=commitdiff;h=a3232de044701bc2b0f7a895d3fb63f1556435de

sadly, I didn't add an explanation of why I did it, but I guess it's probably because some check boxes stayed ungreyed even though the parent widget was greyed out. I'll put together a patch to force graying out of the checkboxes if they are themselves in insensitive state.

Comment 4 Martin Sourada 2009-07-23 19:00:35 UTC
Created attachment 354909 [details]
Patch to correctly grey out check boxes and radio buttons in TreeView

With this patch it should behave like expected. I'll build a package in next few minutes (I need to go through koji as I don't own x86_64, which you seem to have, so it might take a little longer).

Comment 5 Martin Sourada 2009-07-23 19:13:31 UTC
Ok, build done, here you can download the packages to test
http://koji.fedoraproject.org/koji/buildinfo?buildID=115712

Comment 6 Nanley Chery 2009-07-23 21:12:18 UTC
Created attachment 354931 [details]
Software Update NODOKA (PATCHED)

Amazing work Martin. That was a very fast response and the patch works like a charm! I have the patched screenshot attached. Thanks!

Comment 7 Fedora Update System 2009-07-24 01:41:18 UTC
gtk-nodoka-engine-0.7.2-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/gtk-nodoka-engine-0.7.2-5.fc11

Comment 8 Fedora Update System 2009-07-24 12:20:37 UTC
gtk-nodoka-engine-0.7.2-5.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gtk-nodoka-engine-0.7.2-5.fc10

Comment 9 Fedora Update System 2009-07-24 19:39:33 UTC
gtk-nodoka-engine-0.7.2-5.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gtk-nodoka-engine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7984

Comment 10 Fedora Update System 2009-07-27 21:29:19 UTC
gtk-nodoka-engine-0.7.2-5.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gtk-nodoka-engine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-8019

Comment 11 Fedora Update System 2009-08-15 08:07:32 UTC
gtk-nodoka-engine-0.7.2-5.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2009-08-15 08:13:49 UTC
gtk-nodoka-engine-0.7.2-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.