Bug 51349 - anaconda has problems finding partitions with fdisk
Summary: anaconda has problems finding partitions with fdisk
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-09 18:53 UTC by Stephen John Smoogen
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-27 16:56:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stephen John Smoogen 2001-08-09 18:53:59 UTC
Description of Problem:

In using fdisk to set up partitions, I found that disk druid had problems
with finding partitions afterword. 

I was trying out the fdisk option because the Beta3 grub had problems with
the autopartition'd layout. So I removed all the partitions and set them up
like they would be in the 'old days'...

/dev/hdb1   -> /boot
/dev/hdb2   -> extended partition
/dev/hdb5   -> /
/dev/hdb6   -> /home
/dev/hdb7   -> /usr/local
/dev/hdb8   -> <swap>

The first problem was what I would call a UI mis-information... I would
select a partition created but could not edit it until I selected 
'reformat'  the partition. The text area where I would normally enter / or
whatever did not seem to be grayed out and it took a bit of fiddling to
figure out what needed to be done so I could put a partition there.

I also ran into this problem on an install where I had already put the beta
on the system and just wanted to re-install. 

The second problem was a bit more severe, but similar. I tried to go onto
the next stage, but the installer could not find a SWAP partition. It was
clearly marked, but it took a bit of fiddling with the UI of telling it to
reformat the swap partition as a swap partition to get it to work.

Still trying to figure out why auto-partition and GRUB didnt work (/boot
was under 1024 this time).

Comment 1 Glen Foster 2001-08-09 20:11:49 UTC
This defect is considered SHOULD-FIX for Fairfax.

Comment 2 Michael Fulbright 2001-08-10 17:07:27 UTC
For the next release we plan on changing the UI to better indicate this. The
problem you hit is the 'Type' column is overloaded at the momemnt. If there is a
valid filesystem on the partition, we display its type. If there is no
filesystem, we display the partition type code on the partition.

I will see if there is something I will do that won't break translations or
screenshots for the current release.

Comment 3 Michael Fulbright 2001-08-13 15:23:57 UTC
Very similar to bug 51637.

Comment 4 Matt Wilson 2001-08-24 21:29:27 UTC
requires changes to parted scheduled for 1.5 development cycle.  When
verify-probed-fs-with-open is done we'll be in good shape.


Comment 5 Michael Fulbright 2002-01-23 17:57:25 UTC
We made some changes in RC1 that I beleive address these issues.


Note You need to log in before you can comment on or make changes to this bug.