Bug 51351 - i386 german laptop install crashes after selecting "do not make bootdisk" and hitting OK
i386 german laptop install crashes after selecting "do not make bootdisk" and...
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-09 15:02 EDT by Zeke Harris
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-15 14:52:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zeke Harris 2001-08-09 15:02:41 EDT
Description of Problem:
i386/German/CDROM/Gui/LAPTOP - PCMCIA USED
Crashes after selecting "Do not create boot disk" option and hitting OK.

How Reproducible:
Every time Laptop default install is used. Minimal avoids this problem.

Steps to Reproduce:
1. Do a german Laptop CDROM install, with PCMCIA drivers  
2. At Bootdisk screen, select the do not make boot disk option
3. Hit OK

Actual Results:
Traceback

Expected Results:
No bootdisk made and on to next screen

Additional Information:

Traceback (innermost last):
File "/usr/bin/anaconda", line 608, in ?
    intf.run (id, dispatch, configFileData)
File "/usr/lib/anaconda/gui.py", line 348, in run
    self.icw.run (self.runres, configFileData)
File "/usr/lib/anaconda/gui.py", line 776, in run
    mainloop ()
File "/usr/lib/python1.5/site-packages/gtk.py", line 2608, in mainloop
    _gtk.gtk_main()
File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply (self.func, a)
File "/usr/lib/anaconda/gui.py", line 400, in nextClicked
    self.setScreen ()
File "/usr/lib/anaconda/gui.py", line 524, in setScreen
    new_screen = apply (self.currentWindow.getScreen, args)
File "/usr/lib/anaconda/iw/xconfig_gui.py", line 268, in getScreen
    location = available[self.selectedDepth].index(self.selectedRes)
Value Error: list.index(x): x not in list
Comment 1 Glen Foster 2001-08-09 16:03:16 EDT
We (Red Hat) really need to fix this defect before next release.
Comment 2 Jeremy Katz 2001-08-09 16:14:15 EDT
Could we get the entire traceback attached?  Looks like a duplicate of 51273 and
others, but without the rest of the information, it's hard to know for sure
Comment 3 Zeke Harris 2001-08-09 20:47:58 EDT
I can't save the traceback to disk (and not for lack of trying). The same error 
message keeps popping up (in german, so I have no idea what it says) every time 
I try to write out. The floppy *does* write, but it only nukes the disk and 
ends up not actually writing the dumpfile. I end up with a blank disk, no dump, 
and a german error message.
Comment 4 Brent Fox 2001-08-09 23:05:06 EDT
This looks like some problem with the X configuration.  What kind of graphics
chip does this laptop have?
Comment 5 Zeke Harris 2001-08-10 11:19:52 EDT
It's a NeoMagic MagicMedia 256AV (NM2200).
Comment 6 Brent Fox 2001-08-13 18:25:35 EDT
Looks very similar to bug #49178, which was supposedly fixed after beta 1...
Comment 7 Michael Fulbright 2001-08-14 17:20:01 EDT
Unable to reproduce on a laptop here.

We have fixed some issues with X configuration overall, it may very well fix
this issue.

Did it look like you were running in the old 640x480 16 color mode during the
install (everything was dithered and generally ugly looking)?
Comment 8 Zeke Harris 2001-08-15 14:52:32 EDT
Yep, I believe it was.
Comment 9 Michael Fulbright 2001-08-15 16:25:39 EDT
I believe this is now fixed.

Note You need to log in before you can comment on or make changes to this bug.