Bug 513562 - postuninstall script of redhat-menus calls not installed update-desktop-database
Summary: postuninstall script of redhat-menus calls not installed update-desktop-database
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: redhat-menus
Version: 5.5
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Ray Strode [halfline]
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-07-24 09:15 UTC by Peter Bieringer
Modified: 2014-09-08 17:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-02 13:21:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 580728 None None None Never

Internal Links: 580728

Description Peter Bieringer 2009-07-24 09:15:02 UTC
Description of problem:
I can't deinstall redhat-menus (during cleanup of unnecessary RPMs) without --noscripts because it calls not installed update-desktop-database

Version-Release number of selected component (if applicable):
redhat-menus-6.7.8-3.el5

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL 5.3 with minimal setup
2. yum remove redhat-menus
  
Actual results:
  Erasing        : redhat-menus                                      [1/1]
/var/tmp/rpm-tmp.1768: line 1: update-desktop-database: command not found

Removed: redhat-menus.noarch 0:6.7.8-3.el5

and the last line is not valid, RPM is still installed


# rpm -e redhat-menus
/var/tmp/rpm-tmp.83048: line 1: update-desktop-database: command not found
error: %postun(redhat-menus-6.7.8-3.el5.noarch) scriptlet failed, exit status 127



Expected results:

Clean deinstall

Comment 1 Peter Bieringer 2010-08-11 09:04:38 UTC
Still not fixed since a year :-(

Comment 2 RHEL Program Management 2014-03-07 12:52:04 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 3 RHEL Program Management 2014-06-02 13:21:28 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Comment 4 Peter Bieringer 2014-09-08 17:40:26 UTC
WONTFIX accepted


Note You need to log in before you can comment on or make changes to this bug.