This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 513571 - Can't run PulseAudio, useless error message
Can't run PulseAudio, useless error message
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-07-24 05:51 EDT by Bastien Nocera
Modified: 2009-07-24 08:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-24 08:20:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2009-07-24 05:51:17 EDT
kernel-2.6.31-0.68.rc3.fc12.i586
pulseaudio-0.9.16-2.test2.fc12.i586

There's also no "module-detect" in the Fedora packages, so I can't run PulseAudio any more.

I: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
D: core-rtclock.c: Timer slack is set to 50 us.
D: core-util.c: RealtimeKit worked.
I: core-util.c: Successfully gained nice level -11.
I: main.c: This is PulseAudio 0.9.16-test2
D: main.c: Compilation host: i386-redhat-linux-gnu
D: main.c: Compilation CFLAGS: -ggdb -Wall -W -Wextra -pipe -Wno-long-long -Winline -Wvla -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wold-style-definition -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing=2 -Wwrite-strings -Wno-unused-parameter -ffast-math -Wp,-D_FORTIFY_SOURCE=2 -fno-common -fdiagnostics-show-option
D: main.c: Running on host: Linux i686 2.6.31-0.68.rc3.fc12.i586 #1 SMP Tue Jul 14 11:43:11 EDT 2009
D: main.c: Found 2 CPUs.
I: main.c: Page size is 4096 bytes
D: main.c: Compiled with Valgrind support: no
D: main.c: Running in valgrind mode: no
D: main.c: Optimized build: no
D: main.c: All asserts enabled.
I: main.c: Machine ID is 3c64a6fc7b068b76bfd54cce47ceb446.
I: main.c: Session ID is 3c64a6fc7b068b76bfd54cce47ceb446-1248238146.492990-1906854478.
I: main.c: Using runtime directory /home/hadess/.pulse/3c64a6fc7b068b76bfd54cce47ceb446:runtime.
I: main.c: Using state directory /home/hadess/.pulse.
I: main.c: Running in system mode: no
I: main.c: Fresh high-resolution timers available! Bon appetit!
D: memblock.c: Using shared memory pool with 1024 slots of size 64.0 KiB each, total size is 64.0 MiB, maximum usable slot size is 65496
D: database-tdb.c: Opened TDB database '/home/hadess/.pulse/3c64a6fc7b068b76bfd54cce47ceb446:device-volumes.tdb'
I: module-device-restore.c: Sucessfully opened database file '/home/hadess/.pulse/3c64a6fc7b068b76bfd54cce47ceb446:device-volumes'.
I: module.c: Loaded "module-device-restore" (index: #0; argument: "").
D: database-tdb.c: Opened TDB database '/home/hadess/.pulse/3c64a6fc7b068b76bfd54cce47ceb446:stream-volumes.tdb'
I: module-stream-restore.c: Sucessfully opened database file '/home/hadess/.pulse/3c64a6fc7b068b76bfd54cce47ceb446:stream-volumes'.
I: module.c: Loaded "module-stream-restore" (index: #1; argument: "").
D: database-tdb.c: Opened TDB database '/home/hadess/.pulse/3c64a6fc7b068b76bfd54cce47ceb446:card-database.tdb'
I: module-card-restore.c: Sucessfully opened database file '/home/hadess/.pulse/3c64a6fc7b068b76bfd54cce47ceb446:card-database'.
I: module.c: Loaded "module-card-restore" (index: #2; argument: "").
I: module.c: Loaded "module-augment-properties" (index: #3; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9.16/modules/module-udev-detect.so': success
E: module-udev-detect.c: inotify_add_watch() failed: No space left on device
E: module.c: Failed to load  module "module-udev-detect" (argument: ""): initialization failed.
E: main.c: Module load failed.
E: main.c: Failed to initialize daemon.
I: module.c: Unloading "module-device-restore" (index: #0).
I: module.c: Unloaded "module-device-restore" (index: #0).
D: core-subscribe.c: Dropped redundant event due to remove event.
I: module.c: Unloading "module-stream-restore" (index: #1).
I: module.c: Unloaded "module-stream-restore" (index: #1).
D: core-subscribe.c: Dropped redundant event due to remove event.
I: module.c: Unloading "module-card-restore" (index: #2).
I: module.c: Unloaded "module-card-restore" (index: #2).
D: core-subscribe.c: Dropped redundant event due to remove event.
I: module.c: Unloading "module-augment-properties" (index: #3).
I: module.c: Unloaded "module-augment-properties" (index: #3).
D: core-subscribe.c: Dropped redundant event due to remove event.
I: main.c: Daemon terminated.
Comment 1 Lubomir Rintel 2009-07-24 05:57:21 EDT
E: module-udev-detect.c: inotify_add_watch() failed: No space left on device

This doesn't seem like useless error message to me; unless you're not run out of disk space.
Comment 2 Bastien Nocera 2009-07-24 07:11:34 EDT
(In reply to comment #1)
> E: module-udev-detect.c: inotify_add_watch() failed: No space left on device
> 
> This doesn't seem like useless error message to me; unless you're not run out
> of disk space.  

It's useless because I didn't, and inotify doesn't actually need space on the disk to watch a file. It's most likely trying to monitor a file on /sys which would indeed not have any space.
Comment 3 Lennart Poettering 2009-07-24 07:59:40 EDT
You probably ran out of inotify watches whih is signalled by ENOSPC.

Tracker really shouldn't be using inotify it is being designed right now.

Fixed upstream now (I added a longer explanation when ENOSPC is received), will soon enter Rawhide.

http://git.0pointer.de/?p=pulseaudio.git;a=commitdiff;h=2bbdf631f8ef1029558be19bcf8a9176a5932b8b
Comment 4 Lennart Poettering 2009-07-24 08:07:36 EDT
s/it is/as it is/
Comment 5 Bastien Nocera 2009-07-24 08:20:54 EDT
Fine by me.

Note You need to log in before you can comment on or make changes to this bug.