Bug 513575 - pulseaudio is almost unuseable on kernel-2.6.29.6-213.fc11.i686.PAE with snd_intel8x0 sound driver
pulseaudio is almost unuseable on kernel-2.6.29.6-213.fc11.i686.PAE with snd_...
Status: CLOSED DUPLICATE of bug 506075
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-24 06:53 EDT by Mihai Harpau
Modified: 2009-07-28 14:18 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-28 14:14:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
alsa-info.txt obtinut cu "alsa-info.sh --no-upload" (15.96 KB, text/plain)
2009-07-24 07:54 EDT, Mihai Harpau
no flags Details

  None (edit)
Description Mihai Harpau 2009-07-24 06:53:41 EDT
Description of problem:

Jul 24 12:59:48 sysop pulseaudio[2973]: alsa-sink.c: Increasing wakeup watermark to 30.00 ms
Jul 24 12:59:50 sysop pulseaudio[2973]: alsa-sink.c: Increasing wakeup watermark to 40.00 ms
Jul 24 12:59:52 sysop pulseaudio[2973]: alsa-sink.c: Increasing wakeup watermark to 50.00 ms
Jul 24 13:00:02 sysop pulseaudio[2973]: alsa-sink.c: Increasing wakeup watermark to 60.00 ms
Jul 24 13:02:42 sysop pulseaudio[2973]: alsa-sink.c: Increasing wakeup watermark to 70.00 ms
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-sink.c: Increasing wakeup watermark to 80.00 ms
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-sink.c: Increasing minimal latency to 1.00 ms
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c: snd_pcm_avail() returned a value that is exceptionally large: 4294952760 bytes (24347804 ms).
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c: snd_pcm_dump():
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c: Hardware PCM card 0 'Intel ICH6' device 0 subdevice 0
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c: Its setup is:
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   stream       : PLAYBACK
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   access       : MMAP_INTERLEAVED
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   format       : S16_LE
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   subformat    : STD
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   channels     : 2
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   rate         : 44100
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   exact rate   : 44100 (44100/1)
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   msbits       : 16
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   buffer_size  : 16384
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   period_size  : 16384
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   period_time  : 371519
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   tstamp_mode  : ENABLE
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   period_step  : 1
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   avail_min    : 16384
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   period_event : 0
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   start_threshold  : -1
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   stop_threshold   : 1073741824
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   silence_threshold: 0
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   silence_size : 0
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   boundary     : 1073741824
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   appl_ptr     : 9522742
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   hw_ptr       : 9502724
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c: snd_pcm_delay() returned a value that is exceptionally large: 394900 bytes (2238 ms).
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c: snd_pcm_dump():
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c: Hardware PCM card 0 'Intel ICH6' device 0 subdevice 0
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c: Its setup is:
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   stream       : PLAYBACK
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   access       : MMAP_INTERLEAVED
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   format       : S16_LE
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   subformat    : STD
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   channels     : 2
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   rate         : 44100
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   exact rate   : 44100 (44100/1)
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   msbits       : 16
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   buffer_size  : 16384
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   period_size  : 16384
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   period_time  : 371519
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   tstamp_mode  : ENABLE
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   period_step  : 1
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   avail_min    : 16384
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   period_event : 0
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   start_threshold  : -1
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   stop_threshold   : 1073741824
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   silence_threshold: 0
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   silence_size : 0
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   boundary     : 1073741824
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   appl_ptr     : 9602122
Jul 24 13:03:22 sysop pulseaudio[2973]: alsa-util.c:   hw_ptr       : 9503397
Jul 24 13:03:27 sysop pulseaudio[2973]: ratelimit.c: 1193 events suppressed
Jul 24 13:03:32 sysop pulseaudio[2973]: ratelimit.c: 653 events suppressed
Jul 24 13:03:37 sysop pulseaudio[2973]: ratelimit.c: 11316 events suppressed
Jul 24 13:03:42 sysop pulseaudio[2973]: ratelimit.c: 366 events suppressed
Jul 24 13:03:47 sysop pulseaudio[2973]: ratelimit.c: 931 events suppressed
Jul 24 13:03:52 sysop pulseaudio[2973]: ratelimit.c: 1107 events suppressed
Jul 24 13:03:54 sysop pulseaudio[3390]: pid.c: Stale PID file, overwriting.
Jul 24 13:03:55 sysop pulseaudio[3390]: module-alsa-card.c: Failed to find a working profile.
Jul 24 13:03:55 sysop pulseaudio[3390]: module.c: Failed to load  module "module-alsa-card" (argument: "device_id=1 name=pci_8086_266d_sound_card_0 card_name=alsa_card.pci_8086_266d_sound_card_0 tsched=1"): initialization failed.
Jul 24 13:03:59 sysop pulseaudio[3390]: alsa-sink.c: Increasing wakeup watermark to 30.00 ms
Jul 24 13:04:07 sysop pulseaudio[3390]: alsa-sink.c: Increasing wakeup watermark to 40.00 ms
Jul 24 13:04:08 sysop pulseaudio[3390]: alsa-sink.c: Increasing wakeup watermark to 50.00 ms
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-sink.c: Increasing wakeup watermark to 60.00 ms
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c: snd_pcm_avail() returned a value that is exceptionally large: 4294953616 bytes (24347809 ms).
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c: snd_pcm_dump():
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c: Hardware PCM card 0 'Intel ICH6' device 0 subdevice 0
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c: Its setup is:
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   stream       : PLAYBACK
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   access       : MMAP_INTERLEAVED
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   format       : S16_LE
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   subformat    : STD
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   channels     : 2
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   rate         : 44100
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   exact rate   : 44100 (44100/1)
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   msbits       : 16
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   buffer_size  : 16384
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   period_size  : 16384
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   period_time  : 371519
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   tstamp_mode  : ENABLE
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   period_step  : 1
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   avail_min    : 16384
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   period_event : 0
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   start_threshold  : -1
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   stop_threshold   : 1073741824
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   silence_threshold: 0
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   silence_size : 0
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   boundary     : 1073741824
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   appl_ptr     : 757112
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   hw_ptr       : 737308
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c: snd_pcm_delay() returned a value that is exceptionally large: 393652 bytes (2231 ms).
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c: snd_pcm_dump():
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c: Hardware PCM card 0 'Intel ICH6' device 0 subdevice 0
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c: Its setup is:
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   stream       : PLAYBACK
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   access       : MMAP_INTERLEAVED
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   format       : S16_LE
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   subformat    : STD
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   channels     : 2
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   rate         : 44100
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   exact rate   : 44100 (44100/1)
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   msbits       : 16
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   buffer_size  : 16384
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   period_size  : 16384
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   period_time  : 371519
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   tstamp_mode  : ENABLE
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   period_step  : 1
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   avail_min    : 16384
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   period_event : 0
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   start_threshold  : -1
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   stop_threshold   : 1073741824
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   silence_threshold: 0
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   silence_size : 0
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   boundary     : 1073741824
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   appl_ptr     : 836492
Jul 24 13:04:11 sysop pulseaudio[3390]: alsa-util.c:   hw_ptr       : 738079
Jul 24 13:04:12 sysop pulseaudio[3390]: ratelimit.c: 167 events suppressed
Jul 24 13:04:12 sysop pulseaudio[3390]: asyncq.c: q overrun, queuing locally
Jul 24 13:04:12 sysop pulseaudio[3390]: asyncq.c: q overrun, queuing locally
Jul 24 13:04:12 sysop pulseaudio[3390]: asyncq.c: q overrun, queuing locally
Jul 24 13:04:12 sysop pulseaudio[3390]: asyncq.c: q overrun, queuing locally
Jul 24 13:04:12 sysop pulseaudio[3390]: asyncq.c: q overrun, queuing locally
Jul 24 13:04:12 sysop pulseaudio[3390]: asyncq.c: q overrun, queuing locally
Jul 24 13:04:12 sysop pulseaudio[3390]: asyncq.c: q overrun, queuing locally
Jul 24 13:04:12 sysop pulseaudio[3390]: asyncq.c: q overrun, queuing locally
Jul 24 13:04:12 sysop pulseaudio[3390]: asyncq.c: q overrun, queuing locally
Jul 24 13:04:17 sysop pulseaudio[3390]: ratelimit.c: 734 events suppressed
Jul 24 13:04:22 sysop pulseaudio[3390]: ratelimit.c: 13545 events suppressed
Jul 24 13:04:27 sysop pulseaudio[3390]: ratelimit.c: 370 events suppressed
Jul 24 13:04:32 sysop pulseaudio[3390]: ratelimit.c: 366 events suppressed
Jul 24 13:04:37 sysop pulseaudio[3390]: ratelimit.c: 354 events suppressed
Jul 24 13:04:42 sysop pulseaudio[3390]: ratelimit.c: 837 events suppressed
Jul 24 13:04:47 sysop pulseaudio[3390]: ratelimit.c: 1069 events suppressed
Jul 24 13:04:52 sysop pulseaudio[3409]: pid.c: Stale PID file, overwriting.
Jul 24 13:04:52 sysop pulseaudio[3409]: module-alsa-card.c: Failed to find a working profile.
Jul 24 13:04:52 sysop pulseaudio[3409]: module.c: Failed to load  module "module-alsa-card" (argument: "device_id=1 name=pci_8086_266d_sound_card_0 card_name=alsa_card.pci_8086_266d_sound_card_0 tsched=1"): initialization failed.

Version-Release number of selected component (if applicable):
F11 up-to-date on 24-07-2009
kernel-2.6.29.6-213.fc11.i686.PAE
pulseaudio-0.9.15-14.fc11.i586
alsa-lib-1.0.20-1.fc11.i586

How reproducible:


Steps to Reproduce:
1. login to Gnome
2. try to play some audio file with Rhythmbox
3.
  
Actual results:


Expected results:


Additional info:
On kernel-2.6.29.6-211.fc11.i686.PAE pulseaudio work very well!
Comment 1 Mihai Harpau 2009-07-24 07:54:10 EDT
Created attachment 355008 [details]
alsa-info.txt obtinut cu "alsa-info.sh --no-upload"
Comment 2 Mihai Harpau 2009-07-24 09:12:47 EDT
Sorry, the correct text from comment #1 is:
alsa-info.txt provided by "alsa-info.sh --no-upload
Comment 3 Mihai Harpau 2009-07-24 09:18:56 EDT
Output of lspci -n:

00:00.0 0600: 8086:2590 (rev 03)
00:02.0 0300: 8086:2592 (rev 03)
00:02.1 0380: 8086:2792 (rev 03)
00:1c.0 0604: 8086:2660 (rev 03)
00:1d.0 0c03: 8086:2658 (rev 03)
00:1d.1 0c03: 8086:2659 (rev 03)
00:1d.2 0c03: 8086:265a (rev 03)
00:1d.3 0c03: 8086:265b (rev 03)
00:1d.7 0c03: 8086:265c (rev 03)
00:1e.0 0604: 8086:2448 (rev d3)
00:1e.2 0401: 8086:266e (rev 03)
00:1e.3 0703: 8086:266d (rev 03)
00:1f.0 0601: 8086:2641 (rev 03)
00:1f.1 0101: 8086:266f (rev 03)
02:04.0 0280: 8086:4220 (rev 05)
02:06.0 0607: 104c:8031
02:06.1 0607: 104c:8031
02:06.2 0c00: 104c:8032
02:06.3 0180: 104c:8033
02:06.4 0805: 104c:8034
02:06.5 0780: 104c:8035
02:0e.0 0200: 14e4:165e (rev 03)
Comment 4 Naveed Hasan 2009-07-28 14:14:15 EDT

*** This bug has been marked as a duplicate of bug 506075 ***

Note You need to log in before you can comment on or make changes to this bug.