Bug 51365 - up2date doesn't properlly respond to ^C
up2date doesn't properlly respond to ^C
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.3
i386 Linux
low Severity low
: ---
: ---
Assigned To: uopvybqq
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-09 15:58 EDT by Sean Dilda
Modified: 2015-01-07 18:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-09 15:58:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Dilda 2001-08-09 15:58:44 EDT
I run up2date, the GUI window pops up saying its a beta release, then I hit
^C on the terminal I started up2date on.  In the terminal window, up2date
seems to exit, but the GUI window stays there..  I hit 'OK', and it spits
the beta message out to the terminal, then the GUI keeps running like
nothing happened.

When I hit ^C, I expect the program to completely exit, not just pretend to.
Comment 1 Jay Turner 2001-08-09 16:21:41 EDT
The beta window which is popping up is not a permanent part of the
up2date/rhn_register routines, so anything unusual that you are seeing with
respect to that window is really low priority, seeing as it will go away here
shortly.  Closing out as not a bug since that's not a permanent part of the
routines.

Note You need to log in before you can comment on or make changes to this bug.