Bug 513670 - When useFullyQualifiedName is set to TRUE, additions,modifications and deletions should work with Fully Qualified Names
When useFullyQualifiedName is set to TRUE, additions,modifications and deleti...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: sssd (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Hrozek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-24 13:02 EDT by Jenny Galipeau
Modified: 2010-01-12 13:40 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-12 13:39:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jenny Galipeau 2009-07-24 13:02:27 EDT
Description of problem:

When setting useFullyQualifiedNames to TRUE in a domain configuration, you should be able to use the fully qualified names when modifying or deleting users and groups.  One could argue that you should have to use fully qualified names.  Specifically because there could be the same userid or group name that exists in two different domains.

User and group addition, modifications and deletions do not work using fully qualified names.  

If you add a user using @LOCAL:
    sss_useradd -u 1000 -h /home/user1000 -s /bin/bash user1000@LOCAL
You end up with:
    user1000@LOCAL@LOCAL:x:1000:1000:user1000@LOCAL:/home/user1000:/bin/bash

If you add a user with @LOCAL
   sss_useradd -u 1000 -h /home/user1000 -s /bin/bash user1000

Subsequent modification and/or deletions usign fully qualified names fail.
   
Version-Release number of selected component (if applicable):
sssd-debuginfo-0.4.1-1.fc11.i586
sssd-0.4.1-1.fc11.i586

How reproducible:
always

Steps to Reproduce:
1. 
2.
3.
  
Actual results:


Expected results:


Additional info:

sssd.conf tested:

[services]
description =  Local Service Configuration
activeServices = nss, pam
reconnection_retries = 3

[services/nss]
description = NSS Responder Configuration
filterGroups = root
filterUsers = root
debug-level = 4

[services/dp]
description = Data Provider Configuration
debug-level = 4

[services/pam]
description = PAM Responder Configuration

[services/monitor]
description = Service Monitor Configuration

[domains]
description = Domains served by SSSD
domains = LOCAL

[domains/LOCAL]
description = LOCAL Users domain
enumerate = 3
minId = 1000
maxId = 1010
legacy = FALSE
magicPrivateGroups = TRUE
useFullyQualifiedNames = TRUE
provider = local
Comment 1 Jenny Galipeau 2010-01-12 13:40:58 EST
fix verified automated daily acceptance tests for regression

Note You need to log in before you can comment on or make changes to this bug.